В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
lady198026
lady198026
06.05.2023 12:07 •  Информатика

Паскаль. с клавиатуры введены 6 целых чисел. составьте программу, которая найдет из них наибольшее из них. использовать процедуру поиска большего из двух (бид).

Показать ответ
Ответ:
azbyka1234567890
azbyka1234567890
25.05.2020 02:43

//PascalABC.NET 3.4.2

var x, max: integer;

procedure my_max(x1, x2: ^integer);

begin

 if (x2^ > x1^) then x1^ := x2^;

end;

begin

 loop 6 do

 begin

   x := readinteger();

   my_max(@max, @x);

 end;

 write(max);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота