Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
БЕЙТУЛЛА
15.01.2020 08:14 •
Информатика
Паскаль. с решением. много раз пытались решить, но в ответе даёт не то, что нужно. заранее нужно написать любое слово в столбик а)например: слово слов сло сл с б)например: с сл сло слов слово
Показать ответ
Ответ:
z0mD
26.08.2020 12:18
// PascalABC.NET 3.2, сборка 1425 от 22.04.2017
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('Вводите:');
for var i:=1 to s.Length do s[:i+1].Println;
Writeln;
for var i:=s.Length downto 1 do s[:i+1].Println;
end.
Пример
Вводите: слово
с
сл
сло
слов
слово
слово
слов
сло
сл
с
0,0
(0 оценок)
Популярные вопросы: Информатика
эрика86
09.05.2021 20:17
Составить программу нахождения значения функции y=|2x-3|/x^2+5( )...
Olivka09
09.05.2021 20:17
Написать программу в решить с использованием процедур. указать выделенные , решаемые процедурами. последовательность хейеса. дано натуральное число n (n 1). если...
vaceslavsmelev
09.05.2021 20:17
Заполнить type linmass = array [1..1000] of integer; var a : linmass; n, i : ; begin write( количество элементов массива: ); readln(n); for i : = 1 to do begin...
Ok7a
09.05.2021 20:17
Изменить данную программу, так, чтобы она удаляла все отрицательные элементы! type linmass = array [1..100] of integer; var a : linmass; n, i, j, i1 : integer;...
Чикчирик12
13.09.2020 15:24
Придумать три загадки с составом и на что похоже в трех видах например в двух обручах два озера с мостом посеридине состав оправа два стекла дужка на что похоже...
ROUSWOOD
13.09.2020 15:24
Народ, даны 3 числа а, в,с,если выполняется неравенство а в...
maxbf
13.03.2022 19:39
Сообщение записанное с алфавита мощностью 32 символа вес сообщения 100 байтов...
pointbreakk9
24.07.2020 07:14
Каковы этапы работы с информацией?Раскройте их содержание каждого из этапов....
AlbertWasHere
12.03.2020 05:43
Компьютерде орындайық.1. Суреттерге қарап, ақпарат көздері туралы мәтін құрас-тыр. ...
Медет111111
01.02.2022 12:33
Сколько лет первой крепости северо-запада руси? сколько лет каменному храму нашего края?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('Вводите:');
for var i:=1 to s.Length do s[:i+1].Println;
Writeln;
for var i:=s.Length downto 1 do s[:i+1].Println;
end.
Пример
Вводите: слово
с
сл
сло
слов
слово
слово
слов
сло
сл
с