В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
shahboz3
shahboz3
19.04.2023 21:37 •  Информатика

Паскаль(сортировка списка по фамилиям в порядке алфавита). есть , и пример решения. но в коде решения ошибка и поэтому сортировка не происходит, не дописан цикл, не понимаю как записать. условие - произвести сортировку списка студентов по фамилиям по алфавиту, . type st=record f: string; end; var a: array[1..100] of st; g: string; i,j: integer; begin write('n'); readln(n); for i: = 1 to n do begin write('введите фамилии студентов'); read(a[i].f); end; g: ='а'; for i: =1 to n do if a[i].f[1]=g then (здесь нужно дописать еще цикл) begin writeln(a[i].f); end; end.

Показать ответ
Ответ:
pupsik101010
pupsik101010
04.05.2022 18:14
Описываем переменные: max, min, imax,imin,jmax,jmin - все типа integer, если массив "of integer". Присваиваем начальные значения: max:= a[1,1]; min:= a[1,1]; imax,imin,jmax,jmin - все = 1. Открываем двойной цикл (по i  и по j), просматривая все элементы массива, сравниваем их как с max, так и с min. If a[i,j]>max  then begin max:=a[i,j]; imax:=i; jmax:=j end; аналогично: If a[i,j]<min  then begin min:=a[i,j]; imin:=i; jmin:=j end; После окончания цикла меняем индексы максимального элемента на соответствующие индексы минимального и наоборот. Выводим измененный массив.
0,0(0 оценок)
Ответ:
Ксюха12111
Ксюха12111
20.07.2022 02:00

Так как язык не указан, приведу пример на SWI-Prolog.

Код:

read_int(Int) :- read(Int), integer(Int).split_int_by_numbers(0, []) :- !.split_int_by_numbers(N, [Number|Ints]) :- Number is mod(N, 10), RestN is div(N, 10), split_int_by_numbers(RestN, Ints).test_to_div(_, []).test_to_div(N, [Number|Ints]) :- mod(N, Number) =:= 0, test_to_div(N, Ints). test(Int) :- split_int_by_numbers(Int, Numbers), test_to_div(Int, Numbers), write(Int), write(" - Yes!"), nl.test(Int) :- write(Int), write(" - No!"), nl.?- read_int(Int), test(Int).
Напишите программу: С клавиатуры вводится трёхзначное число (число десятков и число единиц не равна
Напишите программу: С клавиатуры вводится трёхзначное число (число десятков и число единиц не равна
Напишите программу: С клавиатуры вводится трёхзначное число (число десятков и число единиц не равна
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота