В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
20Sascha07
20Sascha07
06.11.2022 22:41 •  Информатика

Паскаль,составить программу! 1.дано слово,определить есть ли в нем буква а! паскаль! (ответить на вопрос да или нет)2.дано предложение,определить длину последнего слова.

Показать ответ
Ответ:
natilis
natilis
29.01.2022 03:00
Var     n, m, sum: integer;   begin     sum : = 0;     repeat     writeln('введите числ с которого начинается ряд');     readln(n);     writeln('введите число которым заканчивается ряд');     readln(m);     until n< m;       if odd(n) then n : = n + 1;     if odd(m) then m : = m - 1;     sum : = (n + m) * (m - n + 2) div 4;     writeln('сумма чётных чисел натурального ряда: ', sum); end.
0,0(0 оценок)
Ответ:
МорскойКот
МорскойКот
24.01.2021 13:55
Будут вопросы - задавайте.

type a = array[0..999] of Integer;
var B, num: a; var N, k: integer; 
 
procedure SimpleNumber(B: a);
begin
    for var i := 0 to N-1 do begin
        for var j := 2 to 9 do begin
            if B[i] mod num[j] <> 0 then
                k += 1;
        end;
        if k = 8 then begin
             write('Есть простое число');
            break;
        end
        else if (k <> 8) and (i = N-1) then 
           write('Нет простых чисел');
        k := 0;
    end;
end;

begin
    for var i := 2 to 9 do begin
        num[i] := i;
    end;
    read(N);
    for var i := 0 to N-1 do 
        read(B[i]);
    SimpleNumber(B);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота