В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
elenafilatova11
elenafilatova11
24.01.2020 02:22 •  Информатика

Паскаль составить программу, которая выводит меню и при нажатии вводе цифры вычисляет соответствующее выражение: 1 - y= (a+b)^2 2 - y= a^2-b^2 3 - y= 1/(a+b)

Показать ответ
Ответ:
jesussoul
jesussoul
02.10.2020 05:15
Var i,y,a,b: single;
begin
writeln('Выберите действие: 1)y=(a+b)^2; 2)y=a^2-b^2; 3)y=1/(a+b)');
read(i);
if i=1 then begin
writeln('Введите a и b');
read(a,b);
write('y=',(a+b)*(a+b));
end
else begin
if i=2 then begin
writeln('Введите a и b');
read(a,b);
write('y=',(a*a)-(b*b));
end
else begin
if i=3 then begin
writeln('Введите a и b');
read(a,b);
write('y=',1/(a+b));
end;
end;
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота