В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
7773530
7773530
11.03.2022 10:45 •  Информатика

Паскаль
Составить программу, в которой необходимо создать базу данных, состоящую из трех полей. Далее организовать поиск по всем полям. В программе учитываем, корректность ввода данных в зависимости от назначения поля. Дать право пользователю выбирать по какому полу осуществить поиск. А затем с Желает ли пользователь повторить поиск или закончить выполнение программы. "

Показать ответ
Ответ:
abduboriy2004
abduboriy2004
11.05.2020 01:48
Const 
n=5;

Var
 ar:array[1..n] of integer;
 ar2:array[1..n] of integer;
 i,k:integer;

 function prost(a:integer):boolean;
 var i:integer;
 b:boolean;
  begin
  b:=true;
   for i:=2 to a div 2 do
    if a mod i=0 then
     begin;
      b:=false;
      break;
     end;
   if a=1 then b:=false;
  prost:=b;
 end;

  begin;
 randomize;
 k:=0;
  for i:=1 to n do
   begin;
    ar[i]:=random(101);
    write(ar[i]:4);
   end;
  writeln;
  for i:=1 to n do
  if prost(ar[i]) then
   begin;
    inc(k);
    ar2[k]:=ar[i];
    write(ar2[k]:4);
   end;
end.
0,0(0 оценок)
Ответ:
FoxyzSuper
FoxyzSuper
29.03.2022 09:27

ответ:

американский инженер и , его работы являются синтезом идей с конкретным анализом чрезвычайно сложных проблем их технической реализации  

он является основателем теории информации, нашедшей применение в современных высокотехнологических системах связи. шеннон внес огромный вклад в теорию вероятностных схем, теорию автоматов и теорию систем — области наук, входящие в понятие «кибернетика». в 1948 году предложил использовать слово «бит» для обозначения наименьшей единицы информации (в статье « теория связи»).

объяснение:

клод шеннон является одним из создателей теории информации. именно он придумал такую единицу информации как бит.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота