В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Паскаль, составьте программу вычисления в массиве b(n) минимального среди положительных элементов и его номера

Показать ответ
Ответ:
fasefasefaceface
fasefasefaceface
04.10.2020 04:57
Const N=10;
var a: array [0..N] of integer;
    i, m: integer;
begin
     for i := 0 to N do
         a[i] := random(1000) - 500; { Надо же что-то в массив закинуть =) }
     for i := 0 to N do
         if ((a[i] > 0) and (a[i] > a[m])) then
            m := i;
     writeln('[', m, '] => ', a[m]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота