В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
MoNKinsN
MoNKinsN
12.02.2020 03:47 •  Информатика

Паскаль составьте программу заполнения массива из 100 чисел случайными значениями из диапазона от -20 до 20. подсчитайте в этом массиве количество положительных и количество отрицательных значений.

Показать ответ
Ответ:
Уляна2000002
Уляна2000002
03.07.2020 10:20
Var a:array[1..100] of integer;
i,p,m:integer;
begin
p:=0;
m:=0;
for i:=1 to 100 do begin
a[i]:=random(-20,20);
if a[i]>0 then p+=1 else
m+=1;
end;
writeln('Положительных - ',p,' отрицательных - ',m);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота