В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
HorseOfDeath
HorseOfDeath
31.08.2021 14:46 •  Информатика

Паскаль важно)напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется число, кратное 4. количество чисел не превышает 1000. введённые числа не превышают 30 000. программа должна вывести одно число – максимальное число, кратное 4. пример работы программы:

Показать ответ
Ответ:
danilkudo423
danilkudo423
29.05.2020 12:44

Объяснение:

var A:array [0..30000] of longint;

n,i,max:integer;

begin

read (n);

for i:=1 to n do begin

 A[i]:=random (30000);

 write (A[i],' ');

 end;

max:=A[1];

for i:=1 to n do begin

 if (A[i]>max) and (A[i] mod 4=0) then

 max:=A[i];

 end;

writeln ('Максимальное число кратное 4= ', max);

end.

Если тебе нужно вводить числа с клавиатуры замени строчку

A[i]:=random (30000);  на read (A[i]);

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота