Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Agartala236
22.09.2021 16:32 •
Информатика
Паскаль ввести массив в(n) целых чисел (n> =10). найти сумму последних пяти элементов массива и заменить ею первый элемент массива, если он отрицателен. массив и сумму распечатать.
Показать ответ
Ответ:
егорка158
07.10.2020 15:14
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var b:=ReadArrReal('Вводите:',ReadInteger('n='));
var s:=b.TakeLast(5).Sum;
if b[0]<0 then b[0]:=s;
b.Println; Writeln('Сумма=',s)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
hfyvjfarioS
21.07.2020 22:21
1.Продумайте структуру и создайте таблицу для решения следующей логической задачи.Валихан,Пирмат,Сагын и Канат носят фамилии, начинающиеся на буквы В,П,С,К. Последовательности...
rrurr
14.06.2022 18:02
алгоритмы и программированиеребята с информатикой 7 класс, 6 заданий...
oksyunya
06.09.2022 09:45
ранати ти ИНФОРМАТИКА «РОМАН» и «НОРМА» В квадратах на рисунках заполните пустые клетки буквами H, 0, P, M, А так, чтобы в каждой строке, в каждом столбце и в каждой...
ilkingaraev90
02.04.2022 00:21
Даны два числа. если они не равны, то замените каждое из них большими вывести результат. если они равны, то вывести их удвоенную сумму...
Malinka440
12.12.2021 03:21
Составьте программу заполнения массива из 100 чисел случайными значениями из диапазона от -20 до 20. подсчитайте в этом массиве количество положительных и количество...
pixxxiv
19.09.2021 09:26
Инфа 10 класс.4. выясните значение слова «эмерджентность». какое отношение оно имеет к теме, рассматриваемой в этом параграфе? 5. в чём состоит суть системного...
Asil1231
15.05.2023 00:06
Решите ! 1. перевести числа из двоичной системы счисления в десятичную: 1) 10001112 2) 1100101002 2. 2. перевести число в двоичную систему счисления: 438 3. представить...
СоняШундик
21.01.2020 07:05
Паскаль,написать программу: организовать с клавиатуры ввод n произвольных целых чисел. определить количество отрицательных и сумму положительных....
Цоніма
16.03.2020 19:07
Информатика самый короткий путь...
aosch2k2
19.12.2022 17:32
Написать код к : напишите программу, которая будет определять наибольшую цифру во введенном трехзначном числе....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// Внимание! Если программа не работает, обновите версию!
begin
var b:=ReadArrReal('Вводите:',ReadInteger('n='));
var s:=b.TakeLast(5).Sum;
if b[0]<0 then b[0]:=s;
b.Println; Writeln('Сумма=',s)
end.