В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
nikitakomer
nikitakomer
22.10.2021 04:56 •  Информатика

Паскаль. задается последовательность натуральных чисел. найти среднее арифметических всех отрицательных чисел

Показать ответ
Ответ:
HAHAEZ2010
HAHAEZ2010
16.06.2020 06:56

Решение #1

 

var a:array[1..1000] of integer;

s,i,k,N:integer;

begin

s:=0;

k:=0;

read(N);

for i:=1 to N do

read(a[i]);

for i:=1 to N do

if a[i]<0 then begin

s:=s+a[i];

k:=k+1;

end;

writeln(s/k);

end.

 

Решение #2;

 

var a,i,s,k,N:integer;

begin

k:=0;

s:=0;

read(N);

for i:=1 to N do begin

read(a);

if a<0 then begin

k:=k+1;

s:=s+a;

end;

end;

write(s/k);

end.

 

Оба решение дают один результат, но первое сделан массивом, а второе простым перебором чисел.

 Формат входных данных

Задается натуральное число N

Затем задается N целых чисел 

Формат выходных данных

 Целое число - среднее арифметическое всех отрицательных чисел

 Пример

Вход

5

1 -2 3 -4 5

Выход

-3

 Вопросы в ЛС

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота