перевести из математического вида в программный 2 скиншот, 16-тый пример - Вычислить значение суммы или произведения членов ряда. Значение x задать с клавиатуры.
Напишите программу для цикла FOR.
1 скриншот, 1-ый пример - Вычислите указанное число по итерационной формуле так, чтобы пsо, стоянными остались 3 знака
после запятой. В ответе покажите истинные и вами расчетные значеnн-ия числа, а также количество
Var a:array [1..20] of integer; i,p:integer; n:real; m:longint; begin n:=0; p:=0; m:=1; write ('Массив: '); for i:=1 to 20 do begin a[i]:=random(101)-50; write (a[i],' '); end; for i:=1 to 20 do begin n:=n+a[i]; end; n:=n/20; writeln; writeln; write ('Среднее арифметическое = ',n); for i:=1 to 19 do begin if a[20]<>a[i] then p:=p+1; end; writeln; write ('Кол-во чисел отличных от последнего в массиве = ',p); for i:=1 to 20 do begin if a[i]<0 then m:=m*a[i]; end; writeln; write ('Произведение отрицательных чисел массива = ',m); end.
Выпишем первые 10 строк и посчитаем количество символов a, b и c
i a b c
1 acac 2 0 2
2 abcabc 2 2 2
3 accacc 2 0 4
4 abccabcc 2 2 4
5 acccaccc 2 0 6
6 abcccabccc 2 2 6
7 aa 2 0 8
8 abab 2 2 8
9 aa 2 0 10
10 abab 2 2 10
Как видим, a=2 и не изменяется, b принимает значение 0 для нечетных строк и 1 для четных строк, с принимает значение i+1 для нечетных строк и i для четных.
i,p:integer;
n:real;
m:longint;
begin
n:=0;
p:=0;
m:=1;
write ('Массив: ');
for i:=1 to 20 do
begin
a[i]:=random(101)-50;
write (a[i],' ');
end;
for i:=1 to 20 do
begin
n:=n+a[i];
end;
n:=n/20;
writeln;
writeln;
write ('Среднее арифметическое = ',n);
for i:=1 to 19 do
begin
if a[20]<>a[i] then p:=p+1;
end;
writeln;
write ('Кол-во чисел отличных от последнего в массиве = ',p);
for i:=1 to 20 do
begin
if a[i]<0 then m:=m*a[i];
end;
writeln;
write ('Произведение отрицательных чисел массива = ',m);
end.
2,0,334
Объяснение:
Выпишем первые 10 строк и посчитаем количество символов a, b и c
i a b c
1 acac 2 0 2
2 abcabc 2 2 2
3 accacc 2 0 4
4 abccabcc 2 2 4
5 acccaccc 2 0 6
6 abcccabccc 2 2 6
7 aa 2 0 8
8 abab 2 2 8
9 aa 2 0 10
10 abab 2 2 10
Как видим, a=2 и не изменяется, b принимает значение 0 для нечетных строк и 1 для четных строк, с принимает значение i+1 для нечетных строк и i для четных.
333 - нечетное число, поэтому b=0, а c=333+1=334