Петя недавно узнал, что такое магический квадрат и решил попробовать написать программу, которая будет составлять квадратную таблицу размером 3х3, состоящую из произвольных целых чисел, в которой сумма элементов в каждой строке и в каждом столбце одна и та же. Но Петя - начинающий программист, поэтому он допустил в своей программе ошибку. Программа Пети выводит квадратную матрицу размером 3х3 такую, что если в ней обменять значения ровно двух ячеек, то таблица станет правильной и будет удовлетворять нужному условию.
Например, если в таблице, которую выдала программа Пети
8 1 6
3 2 7
4 9 5
обменять местами числа 2 и 5, то получится правильная таблица
8 1 6
3 5 7
4 9 2
в которой сумма чисел в каждой строке и в каждом столбце одна и та же и равна 15.
Вам будет дана квадратная таблица размера 3х3, заполненная целыми числами. Обменяйте в этой таблице значения ровно двух ячеек так, чтобы сумма чисел в каждой строке и каждом столбце получившейся таблицы была одна и та же.
right;
paint;
right;
right;
paint;
right;
right;
paint;
right;
right;
paint;
right;
right;
paint;
right;
right;
paint;
right;
right;
paint;
right;
down;
left;
paint;
left;
left;
paint;
left;
left;
paint;
left;
left;
paint;
left;
left;
paint;
left;
left;
paint;
left;
left;
paint;
down;
paint;
right;
paint;
right;
paint;
right;
paint;
right;
paint;
right;
paint;
right;
paint;
right;
paint;
right;
paint;
right;
paint;
right;
paint;
right;
paint;
right;
paint;
right;
paint;
right;
paint;
down;
left;
paint;
left;
left;
paint;
left;
left;
paint;
left;
left;
paint;
left;
left;
paint;
left;
left;
paint;
left;
left;
paint;
left;
down;
9*3*N - не может быть больше 54, т.е.
N может быть только 1 или 2. По условию х>=10 -> N=2 (N -порядок числа).
Поэтому искать нужно среди чисел от 11 до 54. Решение - число 15.
var n,m: integer;
begin
write('n = '); readln(n);
if n=2 then
begin m:=11;
repeat
if (m mod 10)*(m div 10)*3=m then
begin
writeln('число: ',m);
m:=55;
end;
m:=m+1;
until m>54;
end
else writeln('нет решения');
end.