В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
askarovavikuly
askarovavikuly
05.01.2023 11:07 •  Информатика

ПИТОН Чтобы как-нибудь скоротать время до утра, Нильс набрал на берегу полную пригоршню плоских камешков, залез на корягу, валявшуюся у самой воды, и стал бросать камешки в море. Да не просто бросать, а так, чтобы они мячиком прыгали по лунной дорожке.

— Три… пять… семь… десять,— считал Нильс каждый удар камешка о воду.— Хорошо бы до самой луны добросить!

Ну, до Луны далеко, а вот камни сосчитать можно попробовать.

Напишите программу, которая выведет все числа, соответствующие отскокам камня от воды.

Формат ввода
Вводится число n, не большее 9, потом проверочное слово.

Затем вводятся строки, пока не будет введена строка ЛУНА. Эта строка служит признаком окончания ввода, в рассмотрении не участвует.

Формат вывода
Начало и конец диапазона для вывода чисел определяются так.

Среди введенных строк рассматриваются только те, у которых в числе, выражающем длину строки, нет цифры n. А среди них найти с наибольшей и наименьшей длиной.

Если в строке встретилось проверочное слово, то ввод нужно прекратить и перейти к выводу.

Вывести нужно все числа от длины большей строки до длины меньшей (включительно) с шагом, равным числу.

Пример 1
Ввод Вывод
3
море
Хорошо бы до самой луны добросить!
Тихонько вздохнув, Нильс выбрался из пещеры.
Ветер улёгся.
Небо очистилось от туч, и большая круглая луна стояла над самым входом в пещеру.
До утра было ещё далеко.
Чуть только он обогнул выступ скалы, как перед ним открылось море.
Оно лежало такое спокойное, точно бури никогда и не бывало.
ЛУНА
80 77 74 71 68 65 62 59 56 53 50 47 44 41 38 35 32 29 26
Пример 2
Ввод Вывод
3
гус
И вдруг Нильс вспомнил: монетка!
Ведь у него есть воронья монетка!
Это будет получше самого плоского камня.
Нильс растянулся на земле.
А монетка покатилась по отлогому берегу.
ЛУНА
40 37 34 31 28

Показать ответ
Ответ:
миса33
миса33
30.04.2020 17:23

Адекватная версия:

PascalABC.NET

begin

 var expr := Readstring();

 expr.Split(' ')[0].Println;

end.

Версия "Нас так учили"

var  

expression: string;

s_index: byte;

begin

 s_index := 1;

 readln(expression);

 while expression[s_index] <> ' ' do begin

   write(expression[s_index]);

   s_index := s_index + 1;

 end;  

 

end.

Объяснение:

Т.к по условию слово - последовательность непробельных символов, ограниченная пробелами или концами строки, то данная программа полностью игнорирует пунктуацию и считает любой символ частью того слова, с которым он не разделён пробелом.

0,0(0 оценок)
Ответ:
voinabeskonechnosti
voinabeskonechnosti
30.04.2020 17:23

Адекватная версия:

PascalABC.NET

begin

 var expr := Readstring();

 expr.Split(' ')[0].Println;

end.

Версия "Нас так учили"

var  

expression: string;

s_index: byte;

begin

 s_index := 1;

 readln(expression);

 while expression[s_index] <> ' ' do begin

   write(expression[s_index]);

   s_index := s_index + 1;

 end;  

 

end.

Объяснение:

Т.к по условию слово - последовательность непробельных символов, ограниченная пробелами или концами строки, то данная программа полностью игнорирует пунктуацию и считает любой символ частью того слова, с которым он не разделён пробелом.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота