Питон
даша часто забывала свой пароль от codeforces, поэтому она решила записать его в тетрадку. но она испугалась, что злоумышленник сможет подсмотреть ее пароль, зайти под ее логином, и украсть все ее решения. поэтому она решила разделить пароль на две части, и записать их отдельно: одну часть в тетрадку по , а другую — в тетрадку по языку.
даша разделила пароль следующим образом. буквы с нечетными номерами (первая, третья, и т. д.) она записала в первую тетрадку, а буквы с четными номерами (вторая, четвертая, и т. д.) — во вторую тетрадку.
теперь даша просит вас написать программу, которая по двум строкам, записанным в тетрадки, восстанавливает ее пароль.
входные данные
ввод содержит две строки, первая строка — это буквы пароля с нечетными номерами, вторая строка — это буквы пароля с четными номерами. обе строки не пустые, состоят только из букв, и имеют длину не больше 10.
выходные данные
выведите одну строку — пароль даши.
примеры
входные данныескопировать
pswr
asod
выходные данныескопировать
password
входные данныескопировать
qet
wr
выходные данныескопировать
qwert
PascalABC.NET 3.2, сборка 1382 от 06.02.2017
Если программа не работает, обновите версию!
№1
begin
var a:=ReadArrInteger('Вводите числа:',ReadInteger('n='));
var im:=a.IndexMax;
Writeln('Максимальный элемент номер ',im+1,' равен ',a[im])
end.
Пример
n= 6
Вводите числа: 13 8 -15 0 16 -24
Максимальный элемент номер 5 равен 16
№2
begin
var a:=ReadArrInteger('Вводите числа:',ReadInteger('n='));
Sort(a,(x,y)->x>y);
a.Println
end.
Пример
n= 5
Вводите числа: 5 -4 6 0 5
6 5 5 0 -4
№3
begin
var a:=ArrRandom(ReadInteger('n='),-54,33); a.Println;
Sort(a,(x,y)->x>y); a.Println
end.
Пример
n= 14
-2 2 -10 17 18 -3 24 -30 -42 12 -11 -53 13 21
24 21 18 17 13 12 2 -2 -3 -10 -11 -30 -42 -53
№4
begin
var a:=ReadArrInteger('Вводите числа:',ReadInteger('n='));
var b:=a.Where(x->x>0); b.Println
end.
Пример
n= 14
Вводите числа: -2 2 -10 17 18 -3 24 -30 -42 12 -11 -53 13 21
2 17 18 24 12 13 21
Из нее вычитаем площадь двери A×B и полученную площадь умножаем на количество теплиц N.
Получаем S=(π×R×(C+R)-А×В)×N
A, B, C, R, N - это исходные данные
// PascalABC.NET 3.2, сборка 1381 от 04.02.2017
begin
var n:=ReadInteger('Количество теплиц:');
var a,b,c,r:real;
Write('Введите радиус теплицы и её длину, м: '); Read(r,c);
Write('Введите размеры двери теплицы, м: '); Read(a,b);
Writeln('Потребуется плёнки, м: ',(pi*r*(c+r)-a*b)*n:0:2)
end.
Пример
Количество теплиц: 7
Введите радиус теплицы и её длину, м: 3.5 18.4
Введите размеры двери теплицы, м: 1.1 1.9
Потребуется плёнки, м: 1670.99