В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
danishvika
danishvika
10.08.2020 04:02 •  Информатика

Питон
Написать программу которая выведет массив состоящий из Х элементов, массив заполнен случайными значениями от -100 до 100. Вывести индекс максимального элемента массива и его значение. Отсортировать массив по возрастанию

Показать ответ
Ответ:
сегго
сегго
04.07.2020 16:12

1)var

a:array[1..5]of integer;

i,n,s:integer;

begin

 writeln('Введите кол-во элементов');

 readln(n);

 writeln('Введите число');

 s:=0;

 for i:=1 to n do begin

   read(a[i]);

   if a[i]>0 then s:=s+a[i]

 end;

 writeln('Сумма положительных элементов массива равна ', s)

end.

2)var

a:array[1..10]of integer;

i,n,P:integer;

begin

 writeln('Введите число элементов');

 readln(n);

 writeln('Введите число');

 P:=1;

 for i:=1 to n do begin

   read(a[i]);

   if a[i] mod 6 = 0  

   then P:=P*a[i]

 end;

 writeln('Произведение элементов массива кратных 6 равна ',P)

end.

3)var

a:array[1..5]of integer;

n,i:integer;

begin

 writeln('Введите кол-во элементов');

 readln(n);

 writeln('Введите число');

 for i:=1 to n do begin

   read(a[i]);

   if a[i]>0 then begin

   a[i]:=a[i]*3;

   writeln('Новый элемент равен: ',a[i])

 end;

 if a[i]<=0 then begin

   a[i]:=a[i]+5;

    writeln('Новый элемент равен: ',a[i])

 end;

 end;

end.

Буду рад если отметишь мой ответ как лучший

0,0(0 оценок)
Ответ:
МОЗГ1987
МОЗГ1987
25.04.2023 05:26

#include <iostream>

using namespace std;

int main()

{

   double a, b, c;

   cin >> a >> b >> c;

   if ((a+b > c) && (a+c > b) && (b+c > a))

   {

       if (a == b)

           if (a == c) cout << "Треугольник равносторонний";

           else cout << "Треугольник равнобедренный";

       else if ((a == c) || (b == c )) cout << "Треугольник равнобедренный";

       else cout << "Треугольник разностронний";

   }

   else cout << "Невозможно построить треугольник";

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота