В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
sidorova123441
sidorova123441
16.01.2021 17:35 •  Информатика

Питон С N-го марта по K-атое марта (включительно) Саша работает над своим блогом.

Если это нечётное число (например, 5 марта), то Саша пишет текст для поста.

Если число оканчивается на 2 (например, 2 или 12 марта), то Саша обрабатывает фото.

Выведите на экран сначала количество дней в период с N по K число месяца, когда мальчик писал текст.

Затем количество дней, когда мальчик обрабатывал фото.

Пример:

Формат входных данных
Два целых числа: 0 < N < K < 32

Формат выходных данных
Два числа через пробел: сначала количество дней для текста, потом количество дней для обработки фото.

Показать ответ
Ответ:
meshiydima
meshiydima
26.11.2022 22:04

Для В допустим, что слева направо.

class BirthDate{

private int day;

private int month;

private int year;

 

BirthDate(int day, int month, int year){

 this.day = day;

 this.month = month;

 this.year = year;

}

public int getDay() {

 return day;

}

public void setDay(int day) {

 this.day = day;

}

public int getMonth() {

 return month;

}

public void setMonth(int month) {

 this.month = month;

}

public int getYear() {

 return year;

}

public void setYear(int year) {

 this.year = year;

}

 

public boolean isOlder(BirthDate bd) {

 return this.year >= bd.getYear() && this.month >= bd.getMonth()  && this.day > bd.getDay();

}

}

class Human{

private BirthDate birthDate;

private String name;

 

Human(String name, BirthDate birthDate){

 this.birthDate = birthDate;

 this.name = name;

}

 

public BirthDate getBirthDate(){

 return this.birthDate;

}

 

public void setBirthDate(BirthDate bd) {

 this.birthDate = bd;

}

 

public String getName(){

 return this.name;

}

 

public void setName(String name) {

 this.name = name;

}

}

public class Task {

 

private static boolean isSumNumberTwoDecimal(int number) {

 int sum = 0;

 while(true) {

  sum += number % 10;

  number /= 10;

  if(number < 1) {

   break;

  }

 }

 return sum < 100;

}

 

private static String whichSeason(int month) {

 if(month >= 1 && month <= 2 && month == 12) {

  return "Winter";

 } else if(month >= 3 && month <= 5) {

  return "Spring";

 } else if(month >= 6 && month <= 8) {

  return "Summer";

 } else if(month >= 9 && month <= 11){

  return "Autumn";

 } else {

  return "There's no such month";

 }

}

 

private static boolean isSameFirstAndSecond(int number, int numeral){

 String sNbr = String.valueOf(number).substring(0, 2);

 return Integer.valueOf(sNbr) == numeral;

}

 

private static boolean isOlder(Human h1, Human h2) {

 return h1.getBirthDate().isOlder(h2.getBirthDate());

}

 

public static void main(String[] args) {

 int number = 2939393;

 System.out.println(isSumNumberTwoDecimal(number));

 //Month and date has correct values

 int month = 10;

 Human vasya = new Human("Vasya", new BirthDate(1, month, 1990));

 Human natalia = new Human("Natalia", new BirthDate(1, month, 1989));

 System.out.println(isOlder(vasya, natalia));

 System.out.println(whichSeason(month));

 System.out.println(isSameFirstAndSecond(number, 29));

}

}

0,0(0 оценок)
Ответ:
Cardboard
Cardboard
24.02.2021 16:05
Using System;using System.Collections.Generic;using System.Linq;using System.Text.RegularExpressions;
namespace Rextester{    public class Program    {        public static void Main(string[] args)        {
                       int distance = 10;             // дистанция в километрах            int loss_of_fuel = 5;         // расход литров бензина на километр            int available_fuel = 100;  // литров бензина в баке                                   if (available_fuel/loss_of_fuel < distance){                    Console.WriteLine("Не хватит");            }else{                    Console.WriteLine("Хватит");            }                    }    }}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота