Питон язык; Напишите программу, которая считывает с клавиатуры любимый цвет пользователя и устанавливает его в качестве цвета текста вывода в консоль. После ввода цвета программа пишет на экран сообщение "У вас отличный цветовой вкус!" в соответсвующем цвете текста.
Цвета, которые программа должна уметь обрабатывать: красный, зелёный, жёлтый, синий, фиолетовый, бирюзовый.
Формат входных данных
Одно слово - цвет
Формат выходных данных
Сообщение "У вас отличный цветовой вкус!" в соответсвующем цвете текста.
2. Управление устройствами и задачами
3. Красный, зеленый, синий
4. Целые числа в памяти компьюте¬ра это:
Дискретное и конечное множество
5. Контроллер
6. Передача данных, передача адресов
7. D
8. Прикладные программы общего назначения и специализированные программы
9. Главная формула информатики?
2i = N
16i = N
2f = Z
2i = M
10. Прикладные программы и системные программы
11. К основным типам устройств оперативной памяти относятся?
Динамическая и статическая память
12. Компьютер
13. Какой универсальный звуко¬вой формат файлов используется для сохранения звука без потерь?
WAV
14. Множество целых чисел в компьютере дискретно, конечно, ограничено
15. В памяти компьютера числа хранятся?
В двоичной сис¬теме счисления
16. Архитектура персонального компьютера это?
Общие принципы построения компьютера
17. Как называется инструмент для работы профессиональных программистов?
Многопользовательские и многозадачные системы программирования
18. Какой термин считается правильным о представлении о множестве целых чисел в математике?
Множество целых чисел дискретно, бесконечно, неограниченно
19. Текстовая информация уже дискретна и состоит из?
Отдельных знаков
20. Какую графику применяют при разработке электронных и полиграфических изданий?
Векторная
auto = false;
var
soldier: array[1..5000]of integer;
n, i, j, k, max, t, d, imax, a, c: integer;
begin
if auto then begin
n := random(5000);
for i := 1 to n do
soldier[i] := random(5000);
end
else begin
readln(n);
for i := 1 to n do
read(soldier[i]);
end;
{сортирововчка}
for i := 1 to n - 1 do
begin
imax := i;
for j := i + 1 to n do
if soldier[j] > soldier[imax] then
imax := j;
max := soldier[i];
soldier[i] := soldier[imax];
soldier[imax] := max;
end;
max := 0;
for i := 1 to n - 1 do
for j := i + 1 to n do
begin
a := soldier[j];
d := soldier[j] - soldier[i];
c := 2;
for k := j + 1 to n do
if soldier[k] = a + d then begin
a := soldier[k];
c := c + 1;
end;
if c > max then max := c;
end;
writeln(max);
end.