ПИТОН. Задания по теме «Ветвление»
Задача № 1
Даны три целых числа. Выбрать из них те, которые принадлежат интервалу [1,3].
Задача № 2
Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется в том случае, если сумма покупки больше 500 руб., в 5% - если сумма больше 1000 руб.
Задача № 3
Вывести на экран синус максимального из 3 заданных чисел.
Задача № 4
Составить программу, которая по данному числу (1-12) выводит название соответствующего ему месяца.
Задача № 5
Дано три числа. Найти количество положительных чисел среди них;
Задача № 6
Если действительные числа x и y – одного знака, найти их среднее геометрическое, в противном случае найти их среднее арифметическое.
Задача № 7
Определить, существует ли треугольник с длинами сторон a, b, c. Если – да, вычислить его площадь по формуле Герона.
Формула Герона имеет вид:
S=p(p-a)(p-b)(p-c), где p=1/2(a+b+c)
day=0
p=N
v=1
поки p>0
пц
p=p-v
v=v*2
day= day+1
кц
Програма матиме вигляд:
#include <iostream>
using namespace std;
int main(int argc, char** argv)
{
int N, day, p, v;
cin>>N;
day=0;
p=N;
v=1;
while (p>0)
{
p=p-v;
v=v*2;
day++;
}
cout<<day;
return 0;
}
Таблиця виконання алгоритму
Объяснение:
Python – багатоцільова мова програмування, яка дозволяє писати код, що добре читається. Відносний лаконізм мови Python дозволяє створити програму, яка буде набагато коротше свого аналога, написаного на іншій мові.
Python - багатоплатформова мова програмування. Це означає, що програми на Python можна запускати в різних операційних системах без будь-яких змін.
Ще однією перевагою Python є його стандартна бібліотека, яка встановлюється разом з Python і містить готові інструменти для роботи з операційною системою, веб-сторінками, базами даних, різними форматами даних, для побудови графічного інтерфейсу програм тощо.
Програми, написані на мові програмування Python, можуть бути як невеликими скриптами, так і складними системами.
Python абсолютно безкоштовний.
Объяснение: