В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Анкляка
Анкляка
16.03.2021 17:25 •  Информатика

Плачу бобриными слезами Питон! Напишите программу, которая ищет среди целых чисел, принадлежащих числовому отрезку числа. Выведите все найденные числа в порядке возрастания, слева от каждого числа выведите его номер по порядку.

Числа aa и bb натуральные числа, вводятся с клавиатуры, каждое с новой строки, причем a
Sample Input:

3532000
3532160
Sample Output:

1 3532007
2 3532019
3 3532021
4 3532033
5 3532049
6 3532091
7 3532103
8 3532121
9 3532147

Показать ответ
Ответ:
alidagalamova2003
alidagalamova2003
14.10.2020 19:12

a=int(input())

b=int(input())

c=b+1

k=0

p=0

for i in range (a,c):

   for j in range (2,i):

       if i%j==0:

           if i==j:

               break

           else:

               k+=1

               break

   if k==0 and i!=1:

       p+=1        

       print (p, i)

   k=0

a=int(input())

b=int(input())

c=b+1

k=0

p=0

for i in range (a,c):

(tab)for j in range (2,i):

(tab)(tab)if i%j==0:

(tab)(tab)(tab)if i==j:

(tab)(tab)(tab)(tab)break

(tab)(tab)(tab)else:

(tab)(tab)(tab)(tab)k+=1

(tab)(tab)(tab)(tab)break

(tab)if k==0 and i!=1:

(tab)(tab)p+=1

(tab)(tab)print (p, i)

(tab)k=0

Объяснение:

Проверять тут: https://repl.it/languages/python3

Остальные компиляторы могут не доводить программу до конца из-за большого количества действий

Если мой ответ оказался Вам полезен, то отметить его, как "лучший"


Плачу бобриными слезами Питон! Напишите программу, которая ищет среди целых чисел, принадлежащих чис
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота