В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
obuhovasveta
obuhovasveta
18.02.2021 04:24 •  Информатика

Площадь треугольника
Напишите программу, которая вычисляет площадь треугольника по методу Герона. Используйте функция round(), чтобы округлить ответ до 5 знака после точки.

Вводные данные: на первой строке дано число N, количество треугольников. Затем на N строках стороны треугольников написанные через пробел.

Выходные данные: для каждого треугольника на N строках значение площади, которое округленно до 5 знака после точки. Используйте функцию для вычисления площади для каждого треугольника.

Ввод:
4
10 19 17
13 11 15
20 20 16
10 12 11

Вывод должен быть таким:
84.71127
69.62893
146.64242
51.52123

Показать ответ
Ответ:
gravasamp
gravasamp
11.10.2020 11:47

from math import sqrt

n = int(input())

output = []

for i in range(n):

   x = [int(k) for k in  input().split()]

   p = sum(x)/2

   output.append(round(sqrt(p*(p-x[0])*(p-x[1])*(p-x[2])), 5))

for i in output:

   print(i)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота