В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

По данным социологов, из N о человек на улицах Харькова за Партию Программистов собираются голосовать M человек. Используя операцию приведения к типу double, напишите программу, которая по заданным N и социологам определить, сколько процентов респондентов собираются голосовать за Партию Программистов. Резульат представьте в виде целого числа, отбросив дробную часть. на С

Показать ответ
Ответ:
omanivchuk
omanivchuk
26.11.2021 01:17

Объяснение:

#include <stdio.h>

#include <math.h>

int main()

{

   int N, M;

   printf("Введите N=");

   scanf("%d", &N);

   printf("Введите M=");

   scanf("%d", &M);

  double result =ceil(((double)M * 100) / (double) N);

  printf("Проценты: %g%%", result);

   

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота