по информатике Задание 3.
Markdown
Not Trusted
Python 3 (ipykernel)
Напишите программу определяющую результат погического вырожения, которое истинно тогда и только тогда, когда координаты (х,у) принадпежат заштрихованной области.
овать эту программу с логических вырожений, без условного оператора.)
from ipython. display import: Image 2mape("fig.png")
# бызов из быблиожени определённой функции
функции и передача ей в качестве араужения пути к
4
5
-5°C Обланно
06.12.2017
uses crt;
Var a,b,c:integer;
Begin
Write('Введите 1-ю сторону: '); Readln(a);
Write('Введите 2-ю сторону: '); Readln(b);
Write('Введите 3-ю сторону: '); Readln(c);
{Проверка на существование треугольника}
if ((a+b)>c) and ((a+c)>b) and ((b+c)>a) then
Begin
if ((a=b)or (b=c) or (a=c)) then
Writeln('Треугольник равнобедренный');
if ((a=b) and (b=c)) then
Writeln('Треугольник равносторонний')
else Writeln('Треугольник разносторонний');
if ((a*a+b*b = c*c) or (a*a+c*c = b*b) or (b*b+c*c = a*a)) then
Writeln('Треугольник прямоугольный');
end
else Writeln('Треугольник нельзя построить');
Readln();
END.
, связанные с определением количества информации, занимают довольно большое место как в общем курсе 9-11 классов, так и при итоговой аттестации разного типа.
обычно решение подобных не представляет трудности для учащихся с хорошими способностями к анализу ситуаций. но большинство
учеников поначалу путаются в понятиях и не знают, как приступить к решению.
тем не менее, к 9-му классу учащиеся уже имеют определенный опыт решения по другим предметам (более всего – ) с применением формул. определить, что в дано, что необходимо найти, и выразить одну переменную
через другую – действия довольно привычные, и с ними справляются даже слабые ученики. представляется возможным ввести некоторые дополнительные формулы в курсе информатики и найти общий стиль их применения в решении .
оттолкнемся от одной из главных формул информатики – формулы хартли
n=2i. при ее использовании учащиеся могут еще не знать понятия логарифма, достаточно вначале иметь перед глазами, а затем запомнить таблицу степеней числа 2 хотя бы по 10-й степени.
при этом формула может применяться в решении разного типа, если правильно определить систему
обозначений.
выделим в системе на количество информации следующих типов:
количество информации при вероятностном подходе;
кодирование положений;
количество информации при алфавитном подходе (кодирование текста);
кодирование графической
информации;
кодирование звуковой информации
все группы a (в случае, если мы имеем дело с равновероятными событиями) решаются непосредственно по формуле хартли с ее привычными обозначениями:
n – количество равновероятных событий;
i – количество бит в сообщении
о том, что событие произошло,
причем в может быть определена любая из переменных с найти вторую. в случае если число n не является непосредственно числом, представляющим ту или иную степень числа 2, количество бит нам необходимо определить «с запасом». так для гарантированного угадывания
числа в диапазоне от 1 до 100 необходимо задать минимально 7 вопросов (27=128).
решение для случаев неравновероятных событий в этой статье не рассматривается.
для решения групп b-e дополнительно введем еще одну формулу:
q=k*i
и определим систему
обозначений для разного типа.
для группы b значение переменных в формуле хартли таково:
i – количество «двоичных элементов», используемых для кодирования;
n – количество положений, которые можно закодировать посредством этих элементов.
так:
два флажка позволяют передать 4 различных сообщения;
с трех лампочек можно потенциально закодировать 8 различных сигналов;
последовательность из 8 импульсов и пауз при передаче информации посредством электрического тока позволяет закодировать 256 различных текстовых знаков;
и т.п.
рассмотрим структуру решения по формуле:
1: сколько существует различных последовательностей из символов «плюс» и «минус» длиной ровно в пять символов?
дано: i = 5
найти: n
решение: n = 25
ответ: 5
каждый элемент в последовательности для кодирования несет один бит информации.
очевидно, что при определении количества элементов, необходимых для кодирования n положений, нас всегда интересует минимально необходимое для этого количество бит.
при однократном кодировании необходимого количества положений мы определяем необходимое количество бит и ограничиваемся формулой хартли. если кодирование проводится несколько раз, то это количество мы обозначаем как k и, определяя общее количество информации для всего кода (q), применяем
вторую формулу.
2: метеорологическая станция ведет наблюдение за влажностью воздуха, результатом которых является целое число от 1 до 100%, которое кодируется посредством минимально возможного количества бит. станция сделала 80 измерений. какой информационный объем результатов
наблюдений.
дано: n = 100; k = 80
найти: q
решение:
по формуле хартли i = 7 (с запасом); q = 80 * 7 = 560
ответ: 560 бит
(если в даны варианты ответов с использованием других единиц измерения количества
информации, осуществляем перевод: 560 бит = 70 байт).
отметим дополнительно, что, если для кодирования используются нe «двоичные», а скажем, «троичные» элементы, то мы меняем в формуле основание степени.