В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ира1029
ира1029
22.07.2020 00:54 •  Информатика

По паскалю! введите три числа a, b, с. определите количество положительных чисел в данном наборе

Показать ответ
Ответ:
mansurevk2005
mansurevk2005
09.07.2020 20:14
Var
  a, b, c: real;
  n: integer;

begin
  Write('Введите через пробел три числа: ');
  Readln(a, b, c);
  if a > 0 then n := 1 else n := 0;
  if b > 0 then n := n + 1;
  if c > 0 then n := n + 1;
  Writeln('Положительных чисел- ', n)
end.

Тестовое решение:
Введите через пробел три числа: -3.54 2.16 4
Положительных чисел- 2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота