В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ДинараДей
ДинараДей
06.12.2022 11:13 •  Информатика

По языку паскаля, завтра уже сдать надо. 1) напишите программу, которая выводит код введенного пользователем символа. программа должна завершать свою работу в результате ввода, например точки. 2)напишите программу, которая выводит на экран первую часть таблицы кодировки символов (от 0 до 127). таблица должна состоять из восьми колонок и шестнадцати строк. в первой колонке должны быть символы с кодом от 0 до 15, во второй от 16 до 31 и т.д.

Показать ответ
Ответ:
jova20011p0bpf9
jova20011p0bpf9
21.07.2020 01:42
1 задача:
program znan1;
uses crt;
var a:char;
begin
clrscr;
readln(a);
while a<>'.' do
begin
writeln(ord(a));
readln(a);
end;
end.

2 задача:
program znan2;
uses crt;
var i,j:integer;
begin
for i:=1 to 16 do
begin
for j:=1 to 8 do
begin
write((i*j-1):5,'-',chr(i*j-1));
end;
writeln;
end;
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота