В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
stas7454
stas7454
25.06.2021 18:02 •  Информатика

Подскажите как отобрать фамилии.напишите программу, которая заполняет с клавиатуры массив 3x5 фамилиями, именами и отчествами (фамилии размещаются в первой строке, имена — во второй, отчества — в третьей). определите, есть ли в списке однофамильцы и выведите на экран их имена и отчества.

Показать ответ
Ответ:
Lara138009
Lara138009
10.11.2022 20:47
получить 14 с наименьшей цифрой - 9 и 5, а 12 - 9 и 3. Ставим 3 впереди, имем 395.

Следующий код на Python это подтверждает:

def change_3dig():
    n = 100
    while n < 1000:
        digits = (n // 100,
                  n % 100 // 10,
              n % 10)
        sums = (digits[0] + digits[1],
                digits[1] + digits[2])
        res = str(max(sums)) + \
          str(min(sums))
        yield (n, int(res))
        n += 1

ans = [(n1, n2) for n1, n2 in change_3dig() if n2 == 1412]
print(min(ans))

Вывод:
(395, 1412)
0,0(0 оценок)
Ответ:
ludvig9
ludvig9
10.11.2022 20:47
1 - сумма двух чисел, 8 - сумма одного из слагаемых первого числа, а также нового, третьего числа. Так как 1 - сумма двух натуральных чисел, легко сделать вывод, что это числа 1 и 0. Значит 8 - сумма чисел либо 8 и 0, либо 7 и 1. Комбинируем числа из 0, 7 и 1, так как это число точно будет меньше, чем состоящее из 1, 0 и 8. Пусть 1 и 0 - первое и второе числа, тогда... ошибка. 8 - сумма 2-го и 3-го чисел. А 0 не может стоять в разряде сотен. Значит комбинируем из 0, 1 и 8: 1 - первое, 0 - второе и 8 - третье; 1+0=1, 0+8=0, вместе 81.
ответ: 108.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота