Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
vikailen
02.10.2020 17:45 •
Информатика
Подскажите, как решить на паскале? участок сада треугольной формы с длинами границ a=3, b=4, c=5. найдите длину ограды и количество удобрений нужных для участка.
Показать ответ
Ответ:
ynifar
12.07.2020 13:25
Program zadacha;
uses crt;
var a, b, c: integer;
u, p, s: real;
begin
clrscr;
write ('vvedite kolichestvo udobrenii, nuzhnyh dlya 1 m^2: ');
readln (u);
write ('vvedite storony uchastka: '); // таким образом можно ввести любые
// стороны, не только 3, 4 и 5
readln (a, b, c);
// можно сразу написать a:=4; b:=3; c:=5;
p:=a+b+c;
writeln (' dlina ogrady - ', p:0:2);
p:=p/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c)); // вычисление площади по формуле Герона
u:=u*s;
writeln ('kolichestvo trebuemyh udobrenii - ', u:0:2);
readkey;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
serg6205
12.03.2020 08:23
Какой минимальный объём памяти (в кбайт) нужно зарезервировать, чтобы можно было сохранить любое растровое изображение размером 512×256 пикселов при условии, что в изображении...
mika183
14.11.2020 14:25
Рисунок размером 512 на 256 пикселей занимает в памяти 80 кбайт (без учёта сжатия). найдите максимально возможное количество цветов в палитре изображения....
Stepan0305
19.07.2020 20:20
Как открыть скрытые файлы на флешке...
alinapavlova
13.02.2022 21:31
Атрибут ALIGN языка гипертекстовой разметки HTML означает: А) высоту столбца таблицы; Б) ширину столбца таблицы; В) цвет ячейки таблицы; Г) выравнивание ячеек таблицы....
Vika3499
23.04.2023 13:59
От программы, записанной на алгоритмическом языке, перейти к записи программы на языке Паскаль. Определите, что будет выведено в результате работы программы, если были введены...
vlada2207
08.07.2022 04:10
1. Определи закономерность и продолжи пропорцию: А) Монитор: вывод= процессор:? Б) Мышь: ввод= диск:? 2.укажите лишнее устройство: а) жёсткий диск б) монитор в) дискета г) лазерный...
Justacookie2003
17.07.2020 17:55
Завдання. В зошиті написати програмний код на мові програмування Python для розв’язування задач: Хоча б одну! Задача 1. Білочки Є n білочок та m горішків, які потрібно розділити...
ученик1443
26.01.2020 17:41
Можете придумать короткую загадку про змею или же про божью коровку ? просто брату нужно , заранее...
spl228
26.01.2020 17:41
Александр разослал в греческие города гонцов с требованием признать его богом. в спарте народное собрание дало ответ если александр хочет быть богом пусть будет им.почему?...
Yliana239990
26.01.2020 17:41
Какая из точек не принадлежит графику функции у = -0,6х + 1? а) (3; -0,8); б) (-3; 0,8); в) (2; -0,2); г) (-2; 2,2)....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
uses crt;
var a, b, c: integer;
u, p, s: real;
begin
clrscr;
write ('vvedite kolichestvo udobrenii, nuzhnyh dlya 1 m^2: ');
readln (u);
write ('vvedite storony uchastka: '); // таким образом можно ввести любые
// стороны, не только 3, 4 и 5
readln (a, b, c);
// можно сразу написать a:=4; b:=3; c:=5;
p:=a+b+c;
writeln (' dlina ogrady - ', p:0:2);
p:=p/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c)); // вычисление площади по формуле Герона
u:=u*s;
writeln ('kolichestvo trebuemyh udobrenii - ', u:0:2);
readkey;
end.