Поле для игры. Код писать на Python3. Для тех, кто хочет обменяться решениями - не отвечайте, а пишите в комменты к этому во Петя создает поле для своей новой игры. Поле разделено на клетки и представляет собой прямоугольник размером N на M клеток. Пусть клетки имеют координаты от 1 до N слева направо по горизонтали и от 1 до M снизу вверх по вертикали.
На этом поле Петя уже разместил супермаркет, который представляет собой прямоугольник размером C на D клеток (C –– размер по горизонтали, D –– по вертикали), и нижняя левая клетка супермаркета имеет координаты A, B на игровом поле (см. примеры и рисунки). Теперь Пете нужно разместить на том же игровом поле здание биржи. Здание биржи представляет собой прямоугольник размером E на F клеток (E –– по горизонтали, F –– по вертикали). Естественно, что здание биржи должно полностью располагаться на игровом поле и не должно иметь общих клеток с супермаркетом (но может касаться его).
Сколькими Петя сможет разместить здание биржи?
Входные данные
Вводятся числа N,M,A,B,C,D,E,F, каждое в отдельной строке. Числа удовлетворяют следующим условиям: 1 ≤ N ≤ 100, 1 ≤ M ≤ 100, 1≤ A ≤N, 1 ≤ B ≤ M, 1 ≤ A + C − 1 ≤ N, 1≤ B + D − 1≤M, 1 ≤ E ≤ N, 1 ≤ F ≤ M.
Выходные данные
Выведите количество разместить здание биржи.
var a: array[1..n] of integer;
i, j, m: integer;
begin
// генерация и вывод
randomize;
for i := 1 to n do a[i] := Random(19)-8;
for i := 1 to n do write(a[i], ' ');
writeln;
// Сортировка
for i := 1 to n-1 do begin
m := i;
for j := i+1 to n do
if a[j] < a[m] then m := j;
if m <> i then begin
j := a[m];
a[m] := a[i];
a[i] := j;
end;
end;
for i := 1 to n do write(a[i], ' ');
writeln;
// поиск наибольшей разности
m := a[2] - a[1];
for i := 3 to n do
if a[i] - a[i-1] > m then
m := a[i] - a[i-1];
writeln ('разность = ', m);
end.
var a,b:array[1..100] of integer; i,j,k,n:integer;
procedure rmassr;
begin
for i:=1 to n do begin
a[i]:=random(10);
end;
end;
procedure rmassy;
begin
for i:=1 to n do begin
readln(a[i]);
end;
end;
procedure rmass();
begin
for i:=1 to n do begin
write(a[i],' ');
end;
end;
procedure newmass;
begin
for i:=1 to n do begin
if a[i] > 0 then b[i]:=a[i];
end;
for i:=1 to n do begin
j:=j+b[i];
end;
writeln('summa = ',j);
end;
begin
clrscr;
randomize;
write('длина массива '); readln(n);
write('1-random; 2-в ручную'); readln(k);
if k = 1 then
rmassr()
else rmassy();
rmass();
writeln();
newmass();
readln
end.