В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ррраша
ррраша
03.03.2022 12:56 •  Информатика

Получить массив х(n) по правилу: хi =1, если в i-м столбце заданной матрицы есть хотя бы один элемент превышающий заданное значение с, иначе xi=0. найти общее число элементов, больших с.

написать программу на с++ ​

Показать ответ
Ответ:
lida20171
lida20171
19.08.2022 20:59
// PascalABC.Net 3.0, сборка 1066

const
  n=5;
var
  a:array[1..n,1..n] of integer;
  x:array[1..n] of double;
  i,j,k:byte;
begin
  Randomize;
  Writeln('*** Исходный массив ***');
  for i:=1 to n do begin
    for j:=1 to n do begin
      a[i,j]:=Random(51)-25;
      Write(a[i,j]:4)
      end;
    Writeln
  end;
  Writeln('*** Массив x ***');
  for j:=1 to n do begin
    x[j]:=0; k:=0;
    for i:=1 to n do
      if a[i,j] mod 2=0 then begin
        x[j]:=x[j]+a[i,j]; Inc(k)
      end;
    if k>0 then x[j]:=x[j]/k;
    Write(x[j]:0:5,' ')
    end;
  Writeln
end.

Тестовое решение:
*** Исходный массив ***
 -10  18  -8 -15   5
 -21 -18   6  -2   9
  -7  22  -4   3  14
  21  16 -10 -18  -9
  17   3 -14 -18  12
*** Массив x ***
-10.00000 9.50000 -6.00000 -12.66667 13.00000
0,0(0 оценок)
Ответ:
stanislavfred
stanislavfred
29.04.2023 15:51

Объяснение:

Платные программы Бесплатные программы (freeware) Операционные системы (для компьютеров) Windows Самая ра операционная система. Легко установить. Понятный интерфейс. Большинство программ работают именно под этой системой. Стоимость: от 3 500 руб. ОС Windows - официальный сайт Есть возможность получить пробную версию системы MacOS Удобная система от Apple, но программы на неё тяжело искать, иногда невозможно. Тем, кто привык к Виндовс, придётся переучиваться. MacOS более безопасна. Стоимость: от 57 000 руб. (поставляется только с устройствами, купить отдельно невозможно).

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота