В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Denhuk
Denhuk
18.09.2021 09:13 •  Информатика

Пользователь программы вводит с клавиатуры два целых положительных числа «а» и «b», задающих диапазон целых
чисел [а;b]. Напишите программу, выводящую в строку через
пробел все простые числа из данного диапазона.

Показать ответ
Ответ:
пппппп41ррр
пппппп41ррр
02.03.2021 16:32

a = int(input())

b = int(input())

for i in range(a, b + 1):

   k = 0

   for j in range(2, i // 2 + 1):

       if i % j == 0:

           k += 1

   if k == 0:

       print(i, end=' ')

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота