Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
soboleff2005
18.04.2022 17:36 •
Информатика
Поменять местами элементы массива стоящие на чётных и нечетных местах (1и2, 3и 4 и тд) решить кумира
Показать ответ
Ответ:
ELOGE
05.10.2020 01:39
Алг массив
нач
цел N = 10
целтаб a[1:N]
цел i, b
нц для i от 1 до N
a[i] := irnd(100)
вывод a[i], " "
кц
вывод нс
нц для i от 1 до div(N,2)
b := a[2*i-1]
a[2*i-1] := a[2*i]
a[2*i] := b
кц
кц
нц для i от 1 до N
вывод a[i], " "
кц
кон
Пример:
37 96 82 5 31 85 85 87 80 38
96 37 5 82 85 31 87 85 38 80
0,0
(0 оценок)
Популярные вопросы: Информатика
виктория1332
29.05.2022 23:31
Это решает мне слова =sum, =min как нужно набирать в программе...
kilutikkkasd
08.03.2022 04:38
На каком языке программирования ведется большинство современных разработок в области ии и машинного обучения?...
fdffxdf
19.05.2021 23:59
Алгоритм присваивающий переменную y значения наибольшей из трёх величин a, b и c. program n_10 var y, a, b, c: integer; begin writeln ( нахождение наибольшей из трёх величин );...
Patriot73
04.04.2021 04:02
Решить задачу. Скорость передачи данных через соединение равна 1024000 бит/с. через данное заведение продают файл размером 3750 байт. Определите время передачи файлов в секунду...
Elli34
26.12.2021 04:12
Составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10 и находит максимальный элемент массива среди элементов с чётными индексами...
gazelle116
26.12.2021 04:12
1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди элементов с нечётными индексами...
4u4undr
26.12.2021 04:12
Для какого из чисел истинно высказывание: не (первая цифра чётная) и (последняя цифра нечётная)? 1) 1234 2) 6843 3) 3561 4) 4562...
AlexLLG
05.06.2021 17:59
Матрица 5 на 5 Паскаль Значения заганять случайно1)1 столбик умножать на 5 столбик2)2 столбик + 4 столбик3)3 столбик умножать на 10...
Renatka96
20.04.2020 05:57
Информатика. Дано логическое выражение:...
linasysueva01
24.04.2022 08:50
Запишіть рівняння взаємодії: барій нітрат+ карбонатна кислота...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
нач
цел N = 10
целтаб a[1:N]
цел i, b
нц для i от 1 до N
a[i] := irnd(100)
вывод a[i], " "
кц
вывод нс
нц для i от 1 до div(N,2)
b := a[2*i-1]
a[2*i-1] := a[2*i]
a[2*i] := b
кц
кц
нц для i от 1 до N
вывод a[i], " "
кц
кон
Пример:
37 96 82 5 31 85 85 87 80 38
96 37 5 82 85 31 87 85 38 80