В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ульяна540
ульяна540
23.07.2022 14:21 •  Информатика

Посчитать количество предложений в файле(тема: строковый тип данных).т.е написать программу

Показать ответ
Ответ:
Loi00
Loi00
22.06.2020 14:41
Не работает с многоточием, если что.
var f:text; c:char; k:integer;
begin
k:=0;
assign(f,'input');
reset(f);
while eof(f)=false do
if eoln(f) then readln(f)
else
begin
read(f,c);
if (c='.') or (c='!') or (c='?') then k:=k+1;
end;
if not((c='.') or (c='!') or (c='?')) then k:=k+1;
close(f);
write(k)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота