В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
BEAR58
BEAR58
17.02.2020 11:26 •  Информатика

Поток данных заканчивается вводом числа 0. Напишите программу, которая считает за триместр по текущим оценкам в потоке

Показать ответ
Ответ:
abduboriy2004
abduboriy2004
11.05.2020 01:48
Const 
n=5;

Var
 ar:array[1..n] of integer;
 ar2:array[1..n] of integer;
 i,k:integer;

 function prost(a:integer):boolean;
 var i:integer;
 b:boolean;
  begin
  b:=true;
   for i:=2 to a div 2 do
    if a mod i=0 then
     begin;
      b:=false;
      break;
     end;
   if a=1 then b:=false;
  prost:=b;
 end;

  begin;
 randomize;
 k:=0;
  for i:=1 to n do
   begin;
    ar[i]:=random(101);
    write(ar[i]:4);
   end;
  writeln;
  for i:=1 to n do
  if prost(ar[i]) then
   begin;
    inc(k);
    ar2[k]:=ar[i];
    write(ar2[k]:4);
   end;
end.
0,0(0 оценок)
Ответ:
danya13112004
danya13112004
07.11.2020 20:39

ответ:Ну тут легко

Например можешь написать про Амёбу или про Бактерии

Объяснение:

1) Амёбы — род микроскопических одноклеточных простейших из семейства Amoebidae. У амёб неправильная, всё время меняющаяся форма из-за временных цитоплазматических выростов, называемых ложноножками или псевдоподиями, которые служат для передвижения и захвата пищи.

2)Протоплазма  — цитоплазма и ядро клетки. Иногда протоплазмой неправильно называют только цитоплазму. Живая протоплазма реагировать и отвечать на раздражение.  Термин «протоплазма» ввёл в 1839 году Ян Пуркине. До середины XIX века считалось, что это второстепенная часть клетки по сравнению с оболочкой. В XIX — начале XX века понятие протоплазмы использовалось широко, а в современной научной литературе почти не встречается.

3) Инфузо́рия-туфелька — вид инфузорий, одноклеточных организмов из группы альвеолят. Иногда инфузориями-туфельками называют и другие виды рода Paramecium. Встречаются в пресных водах. Своё название получила за постоянную форму тела, напоминающую подошву туфли.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота