В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
igorgame39
igorgame39
23.04.2022 20:16 •  Информатика

Пож в с++ напишите программу, которая выполняет реверс массива: меняет местами первый и последний элементы, второй и предпоследний и т.д. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами.

Показать ответ
Ответ:
Fakins
Fakins
03.10.2020 11:17
#include <iostream>
using namespace std;
int main()
{
  int n,i;
  cin >> n;
  int a[n];
  for (i = 1; i <= n; i++)
    cin >> a[i];
  for (i = n; i > 0; i--)
    cout << a[i] << " ";
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота