Практическая работа № 3 Программирование обработки одномерных массивов Цель работы: Изучить типы массивов данных и приобрести навыки по обработке одномерных массивов с использованием языка программирования Pascal. Краткие теоретические сведения: Одномерный массив: Правила определения переменных типа массив. вариант 1: var {раздел описания переменных} : array [ 1.. ] of вариант 2: type (раздел описания типов) = array [ 1.. ] of ; var {раздел описания переменных} : ; обращение по индексу : [ ] ( пример - a[i] ) Оператор цикла с известным числом повторений : Общий вид простого оператора for: For to do Общий вид составного оператора for: For to do begin … end; при уменьшении значения переменной цикла вместо “ to ” используется “downto”
Задание : Составить программу обработки одномерного массива в соответствии с заданием. При составлении программы использовать два определения типа соответственно. Заменить отрицательные элементы массива R(10) значением 0 Контрольные вопросы: 1. Описание одномерного массива? 2. Применение раздела type для описания одномерных массивов? 3. Операция обращения по индексу для одномерного массива? 4. Статический и динамический организации массивов? 5. Какой оператор цикла наиболее предпочтительно использовать при обработке одномерных массивов?
uses crt;
Var mas:array[1..1000, 1..1000] of integer;
N,M,i,j,k:integer;
Begin
Writeln('Введите размер матрицы N*M');
Write('N = ');
readln(N);
Write('M = ');
readln(M);
if (M>1000) or (N>1000) or (M<1) or (N<1)
then
Writeln('Ошибка, указанные значения выходят за пределы матрицы') else
Begin
Writeln('Введите элементы матрицы');
k:=0;
for i:=1 to N do
for j:=1 to M do
Begin
readln(mas[i,j]);
if (mas[i,j] mod 2 = 0) then k:=k+1;
end;
Writeln();
Writeln('Исходная матрица');
for i:=1 to N do
Begin
for j:=1 to M do
Begin
Write(mas[i,j], ' ')
end;
Writeln();
end;
Writeln();
Writeln('Количество четных элементов = ',k);
end;
readln;
end.
По закону дистрибутивности раскроем скобки
(Av¬A)&(AvB)
Av¬A = 1, значит остаётся AvB
2) F =A&(¬AvB)
По тому же закону раскрываем скобки
(A&¬A)v(A&B)
A&¬A = 0, значит остаётся A&B
3. (AvB)&(¬BvA)&(¬CvB)
По закону склеивания (AvB)&(¬BvA) = A , получается, что выражение принимает вид
A&(¬CvB)
Можно раскрыть скобки, получим
A&¬C v A&B
4) F =(1v(AvB))v((AC)&1)
Скобка (1v(AvB)) = 1, так как 1 v ЧТОУГОДНО = 1
Получаем выражение
1v((AC)&1) = 1, так как 1 v ЧТОУГОДНО = 1
ответ 1