В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Anny2404
Anny2404
06.02.2020 17:53 •  Информатика

Практические работы по информатике по теме
«Алгоритмизация и программирование»»
Практическя работа №1.
1. Переведите слова Python и print с английского языка на русский.
Python ¬ print ¬
2. Вася решил дополнить программу так, чтобы она выводила сообщение с его именем. Он записал оператор вывода так:
print 'Привет', Вася!
Эта программа не работает. Запишите правильный вариант:

К какому типу относится эта ошибка?

3. Требуется написать программу, которая складывает два числа и выводит на экран их сумму. Определите входные данные и результат этого алгоритма.
К какому типу относятся входные данные:
Сколько входных значений у алгоритма?
К какому типу относятся результаты:
Сколько результатов у алгоритма?
Обозначьте именами входные данные и результаты и напишите их на стрелках:

Запишите формулу, которая связывает исходные данные и результат:
Место для ввода текста.
4. Требуется написать программу, которая выводит скорость и время движения автомобиля и выводит на экран расстояние, которое он проехал. Определите входные данные и результат этого алгоритма.
К какому типу относятся входные данные:
Сколько входных значений у алгоритма?
К какому типу относятся результаты:
Сколько результатов у алгоритма?
Обозначьте именами входные данные и результаты и напишите их на стрелках:

Запишите формулу, которая связывает исходные данные и результат:
Место для ввода текста.
5. В языке Python целые переменные относятся к типу (классу) int. Выясните, откуда произошло сокращение int в языках программирования:
int – это сокращение от английского слова , которое переводится как .
6. Выделите красным фоном недопустимые имена переменных:
1 Vasya СУ-27 @mail_ru
m11 Петя СУ_27 lenta.ru
1m Митин брат _27 "Pes barbos"
m 1 Quo vadis СУ(27) <Ладья>

7. Что появится на экране после выполнения программы:
c = 5
print( с )
print( 'c' )
ответ:
Чем отличаются два оператора вывода в программе?
Место для ввода текста.
8. Что выведет на экран программма
a = 1
print( a )
a = 5
print( a ) ответ:
Заполните пропуски: «Если переменной присваивается новое значение, то предыдущее значение .»
Выберите правильный вариант: «Переменная в любой момент может иметь ».
9. Чему будут равны значения переменных a и b после выполнения программмы, если вначале они имели значения a = 4 и b = 7? Выполните ручную прокрутку программы.
a b
4 7
a = a + 1
b = b + 1
a = a + b
b = b + a
a = a + 1
ответ: a = b =
10. Что выведет эта программа при a = 4, b = 5 и c = 9?
print( 'a', '+b', =, c )
Место для ввода текста.
11. Исправьте ошибки в операторе вывода,
print( 'c', '-b', =, a )
чтобы при a = 4, b = 5 и c = 9 программа вывела 9–5=4:
Место для ввода текста.

Показать ответ
Ответ:
Qwerty20020505
Qwerty20020505
09.07.2020 17:15
//PascalABC.Net 3.0, сборка 1064
type
  IntArray = array of integer;

var
  rows, cols: integer;
  M: array of IntArray;

begin
  Write('Количество строк и столбцов матрицы: '); Read(rows, cols);
  var Avg: array of double := new double[cols];
  M := new IntArray[rows];
  SetLength(Avg, cols);
  for var i := 0 to rows - 1 do
  begin
    M[i] := ArrRandom(cols, -25, 25);
    M[i].Println(#9)
  end;
  for var j := 0 to cols - 1 do
    Avg[j] := Range(0, rows - 1).Select(x -> M[x, j]).Average;
  Writeln('Наименьшее среднее по столбцам равно ', Avg.Min)
end.

Тестовое решение:
Количество строк и столбцов матрицы: 5 8
-22    -8    12    7    3    -18    8    22
2    -16    17    -13    -10    0    -19    2
20    -21    -6    13    2    -20    25    24
-7    -3    -2    -10    -2    8    18    23
4    -21    -8    8    23    -12    -13    -5
Наименьшее среднее по столбцам равно -13.8
0,0(0 оценок)
Ответ:
Uses Crt;
  const n=5; m=7;
  type Mas = array [1..n, 1..m] of integer;
  var i, j, j1, j2: integer;
      Sumj1, Sumj2: real;
      A: Mas;
begin
 ClrScr;
 Randomize;
 SumJ1:=0; SumJ2:=0;
 for i:=1 to n do
    for j:=1 to m do
    A[i,j]:=random (10);
 WriteLn (' Massiv A: ');
 for i:=1 to n do
   begin
      for j:=1 to m do
      Write (A[i,j]:4);
      WriteLn;
   end; WriteLn;
 repeat
   Write (' Stolbez #1 = ');    ReadLn(j1);
 until (j1>=1) and (j1<=m);
 repeat
   Write (' Stolbez #2 = '); ReadLn(j2);
 until (j2>=1) and (j2<=m) and (j1<>j2);
 for i:= 1 to n do
    SumJ1 := SumJ1+A[i,j1];
 for i:= 1 to n do
   SumJ2:=SumJ2+A[i,j2];
 SumJ1:=SumJ1/n; SumJ2:=SumJ2/n; 
WriteLn;
WriteLn (' Srednee stolbza ', j1, ' = ', SumJ1:4:2);
WriteLn (' Srednee stolbza ', j2, ' = ', SumJ2:4:2); 
ReadLn;
end.
Паскаль.составить программу, вычисляющую среднее значение по двум столбцам матрицы. номера столбцов
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота