Представьте, что вы работаете на заводе (с программистами такое тоже случается) по производству пирожков. Вас по написать программу, которая принимает на вход цену одного пирожка в рублях и копейках, а затем количество пирожков — целое число. Вывести нужно итоговую стоимость пирожков в рублях и копейках через пробел.
19 (10cc)=2^4+2^1+2^0=10011 (2cc)
используя формулу А→В =¬А+В приводим данную формулу в условии к виду:
(X&25=0)+(X&19≠0) + (Х&A≠0)=1
рассмотрим случай, когда
(Х&25 =0) +(X&19≠0) =0 и (Х&A≠0)=1
так как 25 = 11001, то (X&25=0) = 0 (т.е. конъюнкция будет "ложь")
при Х={1; 1000; 1001; 10000; 10001; 11000; 11001}
так как 19=10011, то (Х&19≠0) = 0 при
X={100; 1000; 1100}
общее значение : Х=1000 (2сс) = 8 (10сс)
ответ 8
как я понял по данным задачи К больше или равно А то есть начальное значение S = A, вторую ошибку можно решить просто поменяв местами операторы 7-ой и 8-ой строки(чтобы сначала программа суммировала S=15+15 а потом уже 30+16,46+18...пока S<B а в задаче делается так 16+1,16+17, 30+18,...) в общем:
var a, b, s, k: integer;begin
read(a,b);
s := a;<
k := a;
while s < b do begins := s+k;<k := k+1;<end;writeln(k)end.
если
a=15 b=36
ответ будет :15