В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
fima9
fima9
16.01.2023 20:07 •  Информатика

Принято считать землю идеальной сферой с радиусом r=6371 км. напишите программу расчета расстояния от точки с заданной высотой(значение вводится с клавиатуры)до линии горизонта земли. по информатике язык паскаль

Показать ответ
Ответ:
vfvf2304
vfvf2304
17.01.2020 14:37
Const m = 3;
n = 4;
var a: array[1..m, 1..n] of integer;
b: array[1..n] of integer;
i,j,k,maxm:integer;
begin
  for i:=1 to m do begin
    for j:=1 to n do begin
      write('A[',i,',',j,']= ');
      readln (a[i,j]);
      if a[i,j]<=0 then b[j]:=-1;
    end;
  end;
 
  for i:=1 to n do begin
    if b[i]=0  then begin
      writeln('Столбец №',i,' Все положительные');
      break;
     end
     else
      if i=n then writeln('Таких столбцов не было');
    end;
  for i:=1 to m do begin
    for j:=1 to n do write(a[i,j]:5);
    writeln;
  end;
end.

Тестовое решение:
A[1,1]= 7
A[1,2]= 2
A[1,3]= 1
A[1,4]= -9
A[2,1]= -2
A[2,2]= 2
A[2,3]= 4
A[2,4]= 1
A[3,1]= 7
A[3,2]= 2
A[3,3]= 3
A[3,4]= 1
Столбец №2 Все положительные
    7    2    1   -9
   -2    2    4    1
    7    2    3    1
0,0(0 оценок)
Ответ:
dianaTe
dianaTe
22.10.2022 00:29
1  5- ти л ведро
2  9-ти литровое
3 действие

 №  |  1   |   2  |                                       3

1        0     0              начало
2        5     0         налить 5-ти  литровое из родника
3        0    5          перелить из 5-ти в 9-ти л
4        5    5         налить в 5-ти из родника
5        1   9         из 5-ти долить 9-ти л
6        1    0         вылить воду из 9-ти л
7        0   1          из 5-ти л  перелить в 9-ти
8        5   1         наполнить 5-ти л из родника
9        0    6         из 5-ти л перелить в 9-ти
10      5    6        наполнить 5-ти л из родника
11      2   9          из 5-тил долить 9-ти л
12      2   0        вылить из 9-ти л 
13      0   2        из 5-ти л перелить в 9-ти л
14      5   2       налить из родника  в 5-ти л
15      0   7         вылить из 5-ти л в 9-ти л
16      5   7        набрать из родника в 5-ти л
17    3   9        долить 9-ти л из 5-тил и
                                  в 5-ти л  останутся заветные 3 литра
18      3  0         выливаем из 9-ти л
19                    КОНЕЦ                             
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота