В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ekaterinaparsh1
ekaterinaparsh1
22.05.2021 00:24 •  Информатика

Привет с задачей (именно с удалением максимума)

Задача 4. Видеокарты (язык Python)

В базе одного магазина электроники есть список видеокарт компании NVIDIA разных поколений. Для удобства в списке вместо полных названий хранятся только числа, они обозначают модель и поколение видеокарты. Недавно компания выпустила новую линейку видеокарт, и в итоге самые старшие поколения разобрали за пару дней.

Напишите программу, которая удаляет из этого списка видеокарт наибольшие элементы.

Пример:

Кол-во видеокарт: 5
1 Видеокарта: 3070
2 Видеокарта: 2060
3 Видеокарта: 3090
4 Видеокарта: 3070
5 Видеокарта: 3090

Старый список видеокарт: [ 3070 2060 3090 3070 3090 ]
Новый список видеокарт: [ 3070 2060 3070 ]

Показать ответ
Ответ:
никиумняшка
никиумняшка
11.08.2021 15:40

nvidia_list = []

new_nvidia_list = []

new_new = []

qty = int(input('Кол-во видеокарт: '))

print()

count = 1

for _ in range(qty):

   card = int(input(str(count) + ' Видеокарта: '))

   count += 1

   nvidia_list.append(card)

print('Старый список видеокарт: ', *nvidia_list)

new_new = max(nvidia_list)

new_nvidia_list = [i for i in nvidia_list if i != new_new]

print('Новый список видеокарт: ', new_nvidia_list)


Привет с задачей (именно с удалением максимума) Задача 4. Видеокарты (язык Python) В базе одного маг
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота