Приветик решить задачу, код на Pascal) :з Текстовый файл 24-s1.txt состоит не более чем из 106 заглавных латинских букв (A..Z). Текст разбит на строки различной длины. Определите количество строк, в которых комбинация YZ встречается больше одного раза.
Напишу основные идеи на языке Си,но преобразовать несложно Вам будет.
1. int N,c1,c2,razn,chastn;
scanf ("%d",&N); // запрашиваем двузначное число
c1=N%10;
N/=10;
c2=N%10;
razn=c2-c1; chastn=c2/c1;
2. int Z;
if (Z>0) Z=Z+1;
if (Z==0) Z=10;
3. int Z, c_right, c_left;
c_right=Z%10;
Z=Z/10;
c_left=Z%10;
4. int Z;
if ( Z%2==0 ) четное ;
else нечетное ;
5. int a,b,sum ; //имеем ввиду a<b
do
{ a=a+1;
sum=sum+a;
}
while (a!=b-1); // (a!=b) - если от а до Б включительно
Как то так. Если возникнут вопросы- пишите :)
program raf105;
const
n = 5;
var
a:array[1..n] of integer;
x, counter, i: integer;
begin
writeln('Заполните массив:');
for i:=1 to n do
readln(a[i]);
write('Введите значение элемента, который нужно удалить: ');
readln(x);
for i:=1 to n do
begin
if counter > 0
then a[i-counter]:= a[i];
if (a[i] = x) and (counter < 1)
then counter:= counter + 1;
end;
writeln('Вывод:');
for i:=1 to n-counter do
writeln(a[i]);
end.
2.program raf105;
const
n = 5;
var
a:array[1..n] of integer;
x, counter, i: integer;
begin
writeln('Заполните массив:');
for i:=1 to n do
readln(a[i]);
write('Введите значение элемента, который нужно удалить: ');
readln(x);
for i:=1 to n do
begin
if counter > 0
then a[i-counter]:= a[i];
if a[i] = x
then counter:= counter + 1;
end;
writeln('Вывод:');
for i:=1 to n-counter do
writeln(a[i]);
end.
Язык PascalABC