Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
ЭминГаджиев
29.03.2023 05:24 •
Информатика
Прога на паскале. найти все четырехзначные числа abcd, где цифры a,b,c,d-все разные, и для которых верно: ab-cd=a+b+c+d (желательно это выражение) )
Показать ответ
Ответ:
vidadisaf
07.08.2020 10:17
Var
a, b, c, d: integer;
begin
for a := 1 to 9 do
for b := 0 to 9 do
if b <> a then
for c := 0 to 9 do
if (c <> b) and (c <> a) then
for d := 0 to 9 do
if (d <> a) and (d <> b) and (d <> c) then
if a * b - c * d = a + b + c + d then
writeln(a, b, c, d);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
mt111
23.03.2022 19:19
В электронной таблице выделена группа из 12 ячеек. Она может быть описана диапазоном адресов: 1) А1: В3; 2) А1: В4; 3) А1: С3; 4) А1: С4....
Антон446534
07.06.2021 23:30
Які існують обмеження на використання символів в іменах полів?...
skymiss
31.12.2020 07:03
Определите значение переменной s после фрагмента алгоритма:s:-0нц для i от 1 до 5s:=s+i*iкц С РЕШЕНИЕМ. ...
EgrVir2018
11.03.2022 08:00
Оцените информационный объём аудиофайла длительностью 2 минуты при частоте дискретизации 48000 и разрешении 16 битов. ответ дайте в Мбайтах, округлив до сотых....
Марине1960
12.06.2022 02:24
ОЧЕНЬ 3. Какая информация необходима для создания базы данных?...
Five11
19.08.2021 00:13
Статья, набранная на компьютере, содержит 64 страницы, на каждой странице 40 строк, в каждой строке 40 символов. Определите размер статьи в кодировке, в которой каждый...
shyndari
08.09.2020 02:46
Написать программу для PASCAL найти полную площадь прямоугольной(прямой) призмы...
Енотик83
04.10.2020 12:42
Перевести: 1. С716 = X10 2. 1011002 = X10 3. 56710 = X2 4. 56710 = X16 5. 11w 6. 1358 = Х10 7. 10324= Х10 8. АВ12= Х10 9. 12017= Х10 Решение приводим полностью, а не...
tykuozlli2
20.05.2020 16:52
JavaScript Построить в программе на холсте (canvas) графики функций параболы и гиперболы (на одном холсте, в одной программе). Ветки параболы должны быт направлены вверх,...
GBNMK
15.07.2021 09:02
Составьте алгоритм чертежником в результате выполнения которого в произвольном месте координатной плоскости будет нарисован прямоугольник, длины сторон которого равны...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
a, b, c, d: integer;
begin
for a := 1 to 9 do
for b := 0 to 9 do
if b <> a then
for c := 0 to 9 do
if (c <> b) and (c <> a) then
for d := 0 to 9 do
if (d <> a) and (d <> b) and (d <> c) then
if a * b - c * d = a + b + c + d then
writeln(a, b, c, d);
end.