В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Liza1556
Liza1556
12.04.2020 12:20 •  Информатика

Программа Кумир исполнитель робот составить программу
так чтобы когда в узор ставишь стену робот не разрушался​


Программа Кумир исполнитель робот составить программутак чтобы когда в узор ставишь стену робот не р

Показать ответ
Ответ:
Diana111111112
Diana111111112
05.01.2020 13:57

4 числа => каждое число = 32/4 = 8 бит

1. 11001100.10011000.10111110.01000111

2. 11011110.11000011.10100010.00110010

Сейчас переводим из двоичной в 10 по следующему алгоритму:

Записываем двоичное число: 11001100. Сейчас начиная с ПРАВОГО конца, помечаем разряды(начиная с 0!). Я буду отмечать в фигурных скобках. Получаем:

11001100 = 1{7} 1{6} 0{5} 0{4} 1{3} 1{2} 0{1} 0{0}

И сейчас, чтобы найти десятичный эквивалент двоичному числу, мы считаем сумму вида: берем двоичное число(1 или 0) и умножаем его на 2 в степени разряда. Т.е.:

11001100 = 1*2^7 + 1*2^6 + 0*2^5 + 0*2^4 + 1*2^3 + 1*2^2 + 0*2^1 + 0*2^0 = 128 + 64 + 0 + 0 + 8 + 4 + 0 + 0 = 204

Точно так же делаем для всех оставшихся чисел. Т.е.:

10011000 = 1*2^7 + 1*2^4 + 1*2^3 = 128 + 16 + 8 = 152

10111110 = 1*2^7 + 1*2^5 + 1*2^4 + 1*2^3 + 1*2^2 + 1*2^1 = 128 + 32 + 16 + 8 + 4 + 2 = 190

01000111 = 1*2^6 + 1*2^2 + 1*2^1 + 1*2^0 = 64 + 4 + 2 + 1 = 71

В итоге, получаем IP адрес: 204.152.190.71

Точно так же делаем и для второго адреса:

11011110 = 1*2^7 + 1*2^6 + 1*2^4 + 1*2^3 + 1*2^2 + 1*2^1 = 128 + 64 + 16 + 8 + 4 + 2 = 222

11000011 = 1*2^7 + 1*2^6 + 1*2^1 + 1*2^0 = 128 + 64 + 2 + 1 = 195

10100010 = 1*2^7 + 1*2^5 + 1*2^1 = 128 + 32 + 2 = 162

00110010 = 1*2^5 + 1*2^4 + 1*2^1 = 32 + 16 + 2 = 50

И получаем следующий адрес: 222.195.162.50

0,0(0 оценок)
Ответ:
крымнаш
крымнаш
06.12.2020 05:23
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace СиШарп
{
    class Program
    {
        static void Main(string[] args)
        {
            Console.Write("Введите натуральное число: ");
            int C = int.Parse(Console.ReadLine());
            Console.Write("A = ");
            int A = int.Parse(Console.ReadLine());
            while (C > 0)
            {
                if (C % 10 == A) A = -1;
                C /= 10;
            }
            Console.WriteLine((A > -1?"Верно":"Не верно"));
            Console.ReadKey();
        }
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота