В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
тупой177
тупой177
31.12.2021 01:06 •  Информатика

Программа на с++ напишите программу, которая вводит четыре натуральных числа (a, b, c и d) и находит все пятизначные числа, которые при делении на a в остатке b , а при делении на c в остатке d . входные данные первая входная строка содержит два натуральных числа, разделённые пробелами: a и b. вторая строка содержит натуральные числа c и d, также разделённые пробелом. гарантируется, что 0 ≤ b ≤ a и 0 ≤ d ≤ c. выходные данные программа должна вывести в одну строчку через пробел все пятизначные натуральные числа, которые при делении на a в остатке b, а при делении на c в остатке d . если таких чисел нет, программа должна вывести число -1.

Показать ответ
Ответ:
amalia200030
amalia200030
06.10.2020 23:55
#include <iostream>
using namespace std;

int main(){
int a,b,c,d,o=0;
cin>>a>>b>>c>>d;
for (int i=10000; i<=99999;i++)
  if (i % a ==b && i % c == d)
  {
        cout<<i<<' ';
  o=1;
  }
if (o==0)
    cout<<-1;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота