В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
babikovserega2
babikovserega2
16.10.2022 09:28 •  Информатика

Программа - Паскаль

Задание 1. Вычислите:
а) t and (p mod 2 = 0), при t =true, p =231;
б) (2*x * y div 5>10) or (y>4*x), при х =3, у =10;
в) (x * y mod 3=0) and (y г) not a or (not b), при a = false, b = true.
д) not(a or b ) and not a; при а = true и b = false.

Задание 2. Запишите условное выражение:
а) не нулевое число а – положительно;
б) целое k делится на 7;
в) х лежит вне отрезка [ 0,1];
г) х принадлежит отрезку [2,5] или [-1,1];
в) х лежит вне отрезков [2,5] или [-1,1];
д) целые n и k имеют одинаковую четность;

Задача 1. Машина выехала из пункта А в пункт В, между которыми Sкм. Машина двигалась с постоянной скоростью V и остановилась через t часов. Напишите программу, которая по введенным S, V, t определяет положение машины относительно пункта В: не доехала, приехала, проехала.

Задача 2. Даны величины градусных мер углов треугольника a, b, c. Определите какой это треугольник: прямоугольный, тупоугольный, остроугольный.

Показать ответ
Ответ:
vikagevorgiz
vikagevorgiz
11.01.2022 13:35
// PascalABC.NET 3.2, сборка 1387 от 20.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  var a:=MatrGen(n,n,(i,j)->j=n-1-i?n-i:0);
  a.Println(2)
end.

Примеры
n= 7
  0  0  0  0  0  0  7
  0  0  0  0  0  6  0
  0  0  0  0  5  0  0
  0  0  0  4  0  0  0
  0  0  3  0  0  0  0
  0  2  0  0  0  0  0
  1  0  0  0  0  0  0

n= 12
  0  0  0  0  0  0  0  0  0  0  0 12
  0  0  0  0  0  0  0  0  0  0 11  0
  0  0  0  0  0  0  0  0  0 10  0  0
  0  0  0  0  0  0  0  0  9  0  0  0
  0  0  0  0  0  0  0  8  0  0  0  0
  0  0  0  0  0  0  7  0  0  0  0  0
  0  0  0  0  0  6  0  0  0  0  0  0
  0  0  0  0  5  0  0  0  0  0  0  0
  0  0  0  4  0  0  0  0  0  0  0  0
  0  0  3  0  0  0  0  0  0  0  0  0
  0  2  0  0  0  0  0  0  0  0  0  0
  1  0  0  0  0  0  0  0  0  0  0  0
0,0(0 оценок)
Ответ:
You666
You666
12.08.2021 19:20
Консольное приложение:
const n=9; 
var l:array[1..n] of integer;
i,max,imax,min,imin,s:integer; 
begin
Randomize;
writeln('Массив L:');
for i:=1 to n do
 begin
 l[i]:=random(51);
 write(l[i]:4);
 end;
writeln;
max:=l[1]; imax:=1;
min:=l[1]; imin:=1;
for i:=2 to n do
 begin
 if l[i]>max then begin max:=l[i]; imax:=i; end;
 if l[i]<min then begin min:=l[i]; imin:=i; end;
 end;
writeln('max = l[',imax,'] = ',max);
writeln('min = l[',imin,'] = ',min);
s:=0;
if imax>imin
 then for i:=imin+1 to imax-1 do s:=s+l[i]
 else for i:=imax+1 to imin-1 do s:=s+l[i];
writeln('s = ',s);
end.

Пример:
Массив L:
  31  49  41  15   9  47  37  11  27
max = l[2] = 49
min = l[5] = 9
s = 56
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота