В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ndzandigiv
ndzandigiv
03.01.2023 04:20 •  Информатика

Программа ПИТОН Составьте программу, запрашивающую с клавиатуры значения трех переменных и

проверяющую является ли они тройкой Пифагора, т.е.

2 =

2 +

2

Показать ответ
Ответ:
ra1si1ka1
ra1si1ka1
17.07.2020 06:27

var

 A: array [1..3, 1..5] of Integer;

 i, j: Integer;

 s: Real;

begin

 Randomize;

 WriteLn ('Массив:');

 for i := 1 to 3 do begin   // заполнение массива случайными значениями и вывод для просмотра

   for j := 1 to 5 do begin

     A [i, j] := Random (22) - 11;

     Write (A [i, j], ' ');

   end;

   Writeln;

 end;

 for i := 1 to 3 do begin   // замена элементов с четной суммой индексов на 555

   for j := 1 to 5 do begin

     if (i + j) mod 2 = 0 then

       A [i, j] := 555;

   end;

 end;

 WriteLn;

 WriteLn ('Результат: ');   // вывод результата

 for i := 1 to 3 do begin

   for j := 1 to 5 do begin

     Write (A [i, j], ' ');

   end;

   Writeln;

 end;

end.

0,0(0 оценок)
Ответ:

var

 A: array [1..3, 1..5] of Integer;

 i, j: Integer;

 s: Real;

begin

 Randomize;

 WriteLn ('Массив:');

 for i := 1 to 3 do begin   // заполнение массива случайными значениями и вывод для просмотра

   for j := 1 to 5 do begin

     A [i, j] := Random (22) - 11;

     Write (A [i, j], ' ');

   end;

   Writeln;

 end;

 for i := 1 to 3 do begin   // замена элементов с четной суммой индексов на 555

   for j := 1 to 5 do begin

     if (i + j) mod 2 = 0 then

       A [i, j] := 555;

   end;

 end;

 WriteLn;

 WriteLn ('Результат: ');   // вывод результата

 for i := 1 to 3 do begin

   for j := 1 to 5 do begin

     Write (A [i, j], ' ');

   end;

   Writeln;

 end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота