В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
katya8998
katya8998
10.05.2022 15:49 •  Информатика

Программа получает на вход количество чисел в последовательности, а затем сами числа. количество чисел не превышает 100. введённые числа не превышают 300. программа должна вывести среднее арифметичесткое чисел, трёхзначных, или вывести "no", если таких чисел нет. значение выводить с точностью до сотых.

Показать ответ
Ответ:
азат61
азат61
06.10.2020 23:42
//PascalABC.NET
var
    s, k : integer;
begin
    var n := ReadlnInteger('Сколько будет чисел? ');
    writeln('Вводите числа');
    var a := ReadArrInteger(n);
    for var i:=0 to n-1 do
        if (a[i] > 99) and
            (a[i] < 1000) then begin
            s := s + a[i];
            k += 1
        end;

    if k = 0 then
        writeln('NO')
    else
        writeln('Среднее арифметическое равно ', (s / k):8:2)
end.

Программа получает на вход количество чисел в последовательности, а затем сами числа. количество чис
Программа получает на вход количество чисел в последовательности, а затем сами числа. количество чис
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота