В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Alinatomil63
Alinatomil63
06.11.2020 21:13 •  Информатика

Программа получает на вход последовательность целых чисел, каждое число записано в отдельной строке. Последовательность завершается числом
0, при считывании которого программа должна закончить свою работу и
вывести количество четных положительных членов последовательности (не
считая завершающего числа 0).
Входные данные Выходные данные

1
2 1
-4
0
5

0 0
2
4

Показать ответ
Ответ:
bodydop
bodydop
16.02.2022 07:12

c = 0

while True:

   a = int(input())

   if a == 0:

       break

   if a > 0:

       c += 1

print(c)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота