Программа просит пользователя ввести число в байтах, затем переводит их в кбайты и мегабайты и выводит эти значения на экран. Напишите программный код с комментариями.
ее слово переданной её символьной строки. Слово – это последовательность непробельных символов, ограниченная пробелами или концами строки.
Входные данные
Входная строка содержит произвольную последовательность символов.
Выходные данее слово переданной её символьной строки. Слово – это последовательность непробельных символов, ограниченная пробелами или концами строки.
Входные данные
Входная строка содержит произвольную последовательность символов.
Выходные данее слово переданной её символьной строки. Слово – это последовательность непробельных символов, ограниченная пробелами или концами строки.d
Входные данные
Входная строка содержит произвольную последовательность символов.
Выходные данее слово переданной её символьной строки. Слово – это последовательность непробельных символов, ограниченная пробелами или концами строки.
Входные данные
Входная строка содержит произвольную последовательность символов.
var
N: integer;
a: array [1..1000] of integer;
sum,i,k: integer;
begin
write('Введите размерность массива: ');
readln(N);
write('Введите элементы массива: ');
for i:=1 to N do
read(a[i]);
writeln('Элементы массива a: ');
for i:=1 to N do
write(a[i],' ');
writeln;
sum:=0;
for i:=1 to N do //Условие и проверка отрицательности и делимости элементов
if (a[i]<0) and (i mod 3 = 0) then
sum:=sum+sqr(a[i]);
writeln('Сумма квадратов значений элементов с условием равна: ', sum);
k:=0;
for i:=1 to N do //Условие и проверка положительности элементов
if (a[i]>0) and (a[i]<>sum) then
inc(k); //Сумма положительных элементов
writeln('Количество положительных элементов: ', k);
end.
Объяснение:
ее слово переданной её символьной строки. Слово – это последовательность непробельных символов, ограниченная пробелами или концами строки.
Входные данные
Входная строка содержит произвольную последовательность символов.
Выходные данее слово переданной её символьной строки. Слово – это последовательность непробельных символов, ограниченная пробелами или концами строки.
Входные данные
Входная строка содержит произвольную последовательность символов.
Выходные данее слово переданной её символьной строки. Слово – это последовательность непробельных символов, ограниченная пробелами или концами строки.d
Входные данные
Входная строка содержит произвольную последовательность символов.
Выходные данее слово переданной её символьной строки. Слово – это последовательность непробельных символов, ограниченная пробелами или концами строки.
Входные данные
Входная строка содержит произвольную последовательность символов.
Выходные дан