В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Alexandr2K17
Alexandr2K17
18.08.2020 07:56 •  Информатика

Программа в паскале, . даны два действительных числа. составьте программу, которая меньшее из них заменяет их полусуммой, а большее - их произведением.

Показать ответ
Ответ:
amishka01
amishka01
02.10.2020 06:48
Program gg;
var x,y,c:real;
begin
 read(x,y);
if x>y then
     begin
      c:=y;
      y:=(x+y)/2;
      x:=x*c;
     end
else
   begin
      c:=x;
      x:=(x+y)/2;
      y:=y*c;
     end;
write('x=',x,'y=',y)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота