В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
windi37
windi37
16.06.2021 23:19 •  Информатика

Программирование арифметических операций на языке Ассемблер Составить программу на языке ассемблер для микропроцессора Intel 8080, вычисляющую значение функции Y. Соблюдение указанного приоритета операций обязательно.

Выбрать произвольно адреса ячеек памяти (в пределах адресуемого Intel 8080 пространства) для хранения значений аргументов и значения функции. Составить программу и отладить её в эмуляторе Intel 8080.
Y=x1–(x2+x3–x4

Показать ответ
Ответ:
борщ7
борщ7
14.09.2021 13:38
#include <iostream>
#include <iomanip>
using namespace std; 

int main() {   
    int n,k,ind;
    cout<<"n = ";  cin>>n;
    string a[n][3];
    string inp;
    for (int i=0; i<n; i++) {
        cout<<"record number: "<<i+1<<endl;
        cout<<"name: ";  cin>>a[i][0];
        cout<<"letter: ";  cin>>a[i][1];
        cout<<"password: ";  cin>>a[i][2];
    }   
    cout<<endl;
    cout<<"letter: ";  cin>>inp;
    k=0;
    for (int i=0; i<n; i++)
       if (a[i][1]==inp) {
          k=1; ind=i;
       }
    if (k==0) cout<<"no letter "<<inp<<endl;
    else {
       cout<<"password: ";  cin>>inp;
       if (inp!=a[ind][2]) cout<<"not valid password"<<endl;
    }   
    system("pause");
    return 0;
}
0,0(0 оценок)
Ответ:
ildanmini086
ildanmini086
10.03.2021 09:52

Я никогда не задумывался, что значит для меня мой компьютер, но все-таки это интересный вопрос. Компьютер настолько прочно поселился в моей повседневной жизни и так давно стал частью всего, что я делаю, что­ перестал его замечать и думать о нем. Я его просто использую по мере надобности. Но так получается, что необходим он почти всегда. Если нужно написать реферат, я набираю его на компьютере, если необходимо найти какую-то информацию, я ищу ее в интернете, опять же с компьютера. Даже фильмы мы уже давно смотрим в интернете, так как это намного удобнее и экономит время. Ведь при таком просмотре очень редко может помешать реклама.

Сейчас любые документы, которые необходимо составить, набираются на компьютере, там можно проверить ошибки или найти­ правильную конструкцию предложения. Компьютер может сделать практически все, он считает, он проверяет ошибки, он подчеркивает то, что неправильно, с компьютера можно смотреть фильмы, читать книги, слушать музыку. То, для чего раньше необходимо было иметь множество устройств, сейчас требует только компьютера. Это очень удобно и, естественно,­ все вокруг сейчас используют компьютер и­ все очень этим довольны.

Компьютер очень сильно сэкономить время, хотя, с другой стороны, он наоборот его забирает. Например, если мы начинаем играть в какие-то игры на компьютере или переписываться с друзьями, время просто летит, и никто не замечает, как быстро оно­ проходит. Из-за этого можно ничего не успеть и провести целый день, сидя за компьютером. Для того, чтобы компьютер стал другом и не­ убийцей времени, необходимо уметь контролировать себя и правильно использовать его полезные ресурсы. В таком случае, компьютер сэкономить кучу времени и сделать множество вещей за пару часов. Если же постоянно отвлекаться на социальные сети и интересные картинки, то ничего хорошего из этого не выйдет.

Хотя это очень познавательно и занимательно, и может узнать много интересного, лучше для этого найти свободное время. Скорее всего, если бы у меня сейчас забрали компьютер или ограничили возможность пользоваться им, когда и сколько я захочу, я бы почувствовал себя немного потерянным, потому что он стал необходим. Я думаю, многие могут сказать то же самое, так как все сейчас пользуются компьютерами, больше и меньше. Кроме того, компьютеры с каждым годом все больше модифицируются, и их качества улучшаются практически каждый день. Если раньше были огромные агрегаты, то сейчас можно пользоваться меленькими удобными ноутбуками, которые имеют также отличную мощность.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота